CVE-2002-0475
CVSS5.1
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:07
NMCOS    

[原文]Cross-site scripting vulnerability in phpBB 1.4.4 and earlier allows remote attackers to execute arbitrary Javascript on web clients by embedding the script within an IMG image tag while editing a message.


[CNNVD]PHPBB图象标记存在跨站脚本执行漏洞(CNNVD-200208-094)

        
        PHPBB是一款免费开放源代码的WEB论坛/社区程序,由php语言实现,可以运行在unix/linux、MacOS、Microsoft Windows系统下。
        PHPBB对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        PHPBB支持在帖子中用户使用[img]/[/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        此问题声称在1.4.4版本已经修补,但是发现只对发新贴部分作为修改,攻击者可以在发新贴后在对帖子进行编辑,然后插入包含脚本代码图象标记进行攻击。
        

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:1.4.4
cpe:/a:phpbb_group:phpbb:1.2.1
cpe:/a:phpbb_group:phpbb:1.4.0
cpe:/a:phpbb_group:phpbb:1.2.0
cpe:/a:phpbb_group:phpbb:1.4.1
cpe:/a:phpbb_group:phpbb:1.4.2
cpe:/a:phpbb_group:phpbb:1.0.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0475
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0475
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-094
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4379
(VENDOR_ADVISORY)  BID  4379
http://www.securiteam.com/unixfocus/6W00Q202UM.html
(UNKNOWN)  MISC  http://www.securiteam.com/unixfocus/6W00Q202UM.html
http://www.iss.net/security_center/static/7459.php
(VENDOR_ADVISORY)  XF  phpbb-cross-site-scripting(7459)

- 漏洞信息

PHPBB图象标记存在跨站脚本执行漏洞
中危 输入验证
2002-08-12 00:00:00 2005-10-20 00:00:00
远程  
        
        PHPBB是一款免费开放源代码的WEB论坛/社区程序,由php语言实现,可以运行在unix/linux、MacOS、Microsoft Windows系统下。
        PHPBB对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        PHPBB支持在帖子中用户使用[img]/[/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        此问题声称在1.4.4版本已经修补,但是发现只对发新贴部分作为修改,攻击者可以在发新贴后在对帖子进行编辑,然后插入包含脚本代码图象标记进行攻击。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修复之前暂时关闭Image标记的使用,或者对Image标记进行过滤处理。
        厂商补丁:
        phpBB Group
        -----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        下载最新phpBB 2.0 RC4版本:
        
        http://www.phpbb.com/download.php

- 漏洞信息

4269
phpBB Message Edit IMG BBCode Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate HTML [img] tags upon submission to the message posting script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-03-21 Unknow
2002-03-21 Unknow

- 解决方案

Upgrade to version 2.0.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPBB Image Tag User-Embedded Scripting Vulnerability
Input Validation Error 4379
Yes No
2002-03-27 12:00:00 2009-07-11 11:56:00
Discovery of this issue is credited to "Florian Hobelsberger / BlueScreen" <genius28@gmx.de>.

- 受影响的程序版本

phpBB Group phpBB 1.4.4
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 1.4.2
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 1.4.1
phpBB Group phpBB 1.4 .0
phpBB Group phpBB 1.2.1
phpBB Group phpBB 1.2 .0
phpBB Group phpBB 1.0 .0
phpBB Group phpBB 2.0 RC4
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC3
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC2
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC1
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 Beta 1
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9

- 不受影响的程序版本

phpBB Group phpBB 2.0 RC4
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC3
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC2
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC1
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 Beta 1
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9

- 漏洞讨论

phpBB is free, open-source web forums software that is written in PHP and backended by MySQL. It will run on most Unix and Linux variants, as well as Microsoft Windows operating systems.

phpBB includes functionality to allow forum users to post images in messages. To post an image, a user simply includes a link to the image inside of [img] tags. However, phpBB does not adequately filter script code from image tags, making it prone to injection of arbitrary attacker-supplied script code.

This issue may be exploited by an attacker to steal cookie-based authentication credentials from legitimate users of the forum software.

It should be noted that an attempt was made to address this issue in version 1.4.4. However, it has been found that script code was only being filtered from image tags when a new post was created. An attacker may still go back and edit a post to include malicious image tags containing script code.

phpBB2 releases are reportedly not affected by this issue.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Unconfirmed reports suggest this issue is not present in phpBB2. A solution for affected users may be to upgrade. However, it should be noted that phpBB2 is still in the development stage.

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站