CVE-2002-0474
CVSS5.1
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:07
NMCOS    

[原文]Cross-site scripting vulnerability in ZeroForum allows remote attackers to execute arbitrary Javascript on web clients by embedding the script within IMG image tag.


[CNNVD]ZeroForum图象标记跨站脚本执行漏洞(CNNVD-200208-240)

        
        ZeroForum是一款基于WEB的论坛程序,运行在多种Unix和Linux系统下,也可运行于Windows平台下,由PHP实现并可用多种数据库平台支持。
        ZeroForum对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        ZeroForum支持在帖子中用户使用[img]/[/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0474
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0474
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-240
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4394
(VENDOR_ADVISORY)  BID  4394
http://www.securityfocus.com/archive/1/264897
(VENDOR_ADVISORY)  BUGTRAQ  20020329 Re:[Advisory] phpBB 1.4.4 still suffers from Cross Site Scripting Vulnerability
http://www.iss.net/security_center/static/8702.php
(VENDOR_ADVISORY)  XF  zeroforum-img-css(8702)

- 漏洞信息

ZeroForum图象标记跨站脚本执行漏洞
中危 输入验证
2002-08-12 00:00:00 2005-10-20 00:00:00
远程  
        
        ZeroForum是一款基于WEB的论坛程序,运行在多种Unix和Linux系统下,也可运行于Windows平台下,由PHP实现并可用多种数据库平台支持。
        ZeroForum对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        ZeroForum支持在帖子中用户使用[img]/[/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修复之前暂时关闭Image标记的使用。
        厂商补丁:
        ZeroForum
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://zeroforum.com/

- 漏洞信息

9258
ZeroForum IMG Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ZeroForum contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied data contained in IMG tags. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-03-28 Unknow
2002-03-28 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

ZeroForum User-Embedded Scripting Vulnerability
Input Validation Error 4394
Yes No
2002-03-29 12:00:00 2009-07-11 11:56:00
Reported by altomo <altomo@digitalgangsters.net>.

- 受影响的程序版本

ZeroForum ZeroForum 1.0

- 漏洞讨论

ZeroForum allows forum users to post images in messages. It is reportedly possible for attackers to cause script code to be embedded in the the image tags.

This may allow for an attacker to compromise the accounts of other users.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站