CVE-2002-0467
CVSS10.0
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:06
NMCOS    

[原文]Buffer overflows in Ecartis (formerly Listar) 1.0.0 before snapshot 20020125 allows remote attackers to execute arbitrary code via (1) address_match() of mystring.c or (2) other functions in tolist.c.


[CNNVD]Ecartis/Listar远程缓冲区溢出漏洞(CNNVD-200208-150)

        
        Ecartis是Listar软件的新名字,Listar是一个邮件列表管理软件包,运行于Linux、BSD和其他Unix类操作系统下。
        Ecartis软件实现上存在缓冲区溢出漏洞,可能使远程攻击者通过溢出攻击在主机上执行任意指令。
        Ecartis对用户输入未做充分过滤,远程攻击者可能通过提交精心构造的数据给服务器,可能导致缓冲区溢出使攻击者执行任意指令,通常Listar是以listar用户的身份执行的,所以攻击者可能得到一般本地普通用户访问权限。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:listar:listar:0.129a
cpe:/a:ecartis:ecartis:1.0.0_snapshot_2002-01-21
cpe:/a:listar:listar:0.126a
cpe:/a:listar:listar:0.127a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0467
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0467
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-150
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4176
(VENDOR_ADVISORY)  BID  4176
http://www.iss.net/security_center/static/8284.php
(VENDOR_ADVISORY)  XF  ecartis-mystring-bo(8284)
http://www.securityfocus.com/archive/1/261209
(VENDOR_ADVISORY)  BUGTRAQ  20020310 Ecartis/Listar multiple vulnerabilities
http://www.ecartis.org/
(UNKNOWN)  CONFIRM  http://www.ecartis.org/
http://www.debian.org/security/2002/dsa-123
(UNKNOWN)  DEBIAN  DSA-123
http://archives.neohapsis.com/archives/vulnwatch/2002-q1/0063.html
(UNKNOWN)  VULNWATCH  20020311 [VulnWatch] Ecartis/Listar multiple vulnerabilities

- 漏洞信息

Ecartis/Listar远程缓冲区溢出漏洞
危急 边界条件错误
2002-08-12 00:00:00 2005-10-20 00:00:00
远程  
        
        Ecartis是Listar软件的新名字,Listar是一个邮件列表管理软件包,运行于Linux、BSD和其他Unix类操作系统下。
        Ecartis软件实现上存在缓冲区溢出漏洞,可能使远程攻击者通过溢出攻击在主机上执行任意指令。
        Ecartis对用户输入未做充分过滤,远程攻击者可能通过提交精心构造的数据给服务器,可能导致缓冲区溢出使攻击者执行任意指令,通常Listar是以listar用户的身份执行的,所以攻击者可能得到一般本地普通用户访问权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 设置访问过滤,只允许可信用户能访问到此程序。
        厂商补丁:
        Ecartis
        -------
        目前厂商已经发布了升级程序以修复这个安全问题,请到厂商的站点下载:
        Ecartis Upgrade ecartis-1.0.0-snap20020125.tar.gz
        ftp://ftp.ecartis.org/pub/ecartis/snapshots/tar/ecartis-1.0.0-snap20020125.tar.gz
        Ecartis Upgrade ecartis-1.0.0-snap20020125.i386.rpm
        ftp://ftp.ecartis.org/pub/ecartis/snapshots/rpm/ecartis-1.0.0-snap20020125.i386.rpm

- 漏洞信息

9800
Ecartis Header Comparison Multiple Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-02-24 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Ecartis/Listar Buffer Overflow Vulnerability
Boundary Condition Error 4176
Yes No
2002-01-09 12:00:00 2009-07-11 10:56:00
Credited to funkysh@kris.top.pl.

- 受影响的程序版本

Listar Listar 0.129 a
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
Listar Listar 0.127 a
Listar Listar 0.126 a
Ecartis Ecartis 1.0 .0 snapshot 20020121
Listar Listar 0.129 a
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
Ecartis Ecartis 1.0 .0 snapshot 20020125

- 不受影响的程序版本

Listar Listar 0.129 a
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
Ecartis Ecartis 1.0 .0 snapshot 20020125

- 漏洞讨论

Ecartis is the new name for the Listar software product. Listar is a mailing list management package for Linux, BSD, and other Unix like operating systems.

A vulnerability has been announced in some versions of Ecartis and Listar. It is possible for user supplied input to overflow a buffer. This may result in stack data being overwritten with user supplied values, including the return address of a function call. If successfully exploited, this may result in the execution of arbitrary code.

Listar normally runs as the non-privileged user 'listar'. However, exploitation of this vulnerability may result in local access for an attacker. From a local standpoint, further elevation of privileges may be easier to obtain.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Updates are available:


Listar Listar 0.126 a

Listar Listar 0.127 a

Listar Listar 0.129 a

Ecartis Ecartis 1.0 .0 snapshot 20020121

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站