CVE-2002-0451
CVSS7.5
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:03
NMCO    

[原文]filemanager_forms.php in PHProjekt 3.1 and 3.1a allows remote attackers to execute arbitrary PHP code by specifying the URL to the code in the lib_path parameter.


[CNNVD]PHPprojekt远程文件包含执行任意命令漏洞(CNNVD-200208-004)

        
        PHPprojekt是一款免费开放源代码的PHP组件程序包、包括日历、项目管理、时间卡系统、文件管理、联系人管理、邮件客户端和其他9项模块。运行在多种Linux和Unix系统平台下,也可运行在Microsoft Windows操作系统下。
        PHPprojekt在文件管理模块下存在漏洞,远程攻击者可以通过提交包含远程主机上的脚本代码进行攻击。
        攻击者可以通过直接访问文件管理模式和并指定模块包含远程攻击者控制主机下建立的任意文件进行攻击,如果远程包含的文件是PHP脚本,此脚本将被系统执行。问题存在于filemanager/filemanager_forms.php的第一行:
        include_once("$lib_path/access_form.inc.php");
        攻击者可能利用此漏洞以httpd的权限在目标系统执行任意命令。
        能否成功利用此漏洞依靠主机系统上的php配置,如果php.ini中的'all_url_fopen'选项被设置成'off',此攻击将失败。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpprojekt:phpprojekt:3.1
cpe:/a:phpprojekt:phpprojekt:3.1a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0451
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0451
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-004
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4284
(VENDOR_ADVISORY)  BID  4284
http://www.iss.net/security_center/static/8448.php
(VENDOR_ADVISORY)  XF  phpprojekt-filemanager-include-files(8448)
http://www.securityfocus.com/archive/1/261676
(VENDOR_ADVISORY)  BUGTRAQ  20020313 Command execution in phprojekt.
http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=19&mode=&order=
(UNKNOWN)  CONFIRM  http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=19&mode=&order=

- 漏洞信息

PHPprojekt远程文件包含执行任意命令漏洞
高危 未知
2002-08-12 00:00:00 2005-05-02 00:00:00
远程  
        
        PHPprojekt是一款免费开放源代码的PHP组件程序包、包括日历、项目管理、时间卡系统、文件管理、联系人管理、邮件客户端和其他9项模块。运行在多种Linux和Unix系统平台下,也可运行在Microsoft Windows操作系统下。
        PHPprojekt在文件管理模块下存在漏洞,远程攻击者可以通过提交包含远程主机上的脚本代码进行攻击。
        攻击者可以通过直接访问文件管理模式和并指定模块包含远程攻击者控制主机下建立的任意文件进行攻击,如果远程包含的文件是PHP脚本,此脚本将被系统执行。问题存在于filemanager/filemanager_forms.php的第一行:
        include_once("$lib_path/access_form.inc.php");
        攻击者可能利用此漏洞以httpd的权限在目标系统执行任意命令。
        能否成功利用此漏洞依靠主机系统上的php配置,如果php.ini中的'all_url_fopen'选项被设置成'off',此攻击将失败。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在php.ini中设置'all_url_fopen'选项为'off'。
        厂商补丁:
        PHPProjekt
        ----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        PHPProjekt PHPProjekt 3.1a:
        PHPProjekt Upgrade phprojekt.zip
        ftp://ftp.phprojekt.com/phprojekt.zip
        PHPProjekt Upgrade phprojekt.tar.gz
        ftp://ftp.phprojekt.com/phprojekt.tar.gz
        PHPProjekt PHPProjekt 3.1:
        PHPProjekt Upgrade phprojekt.zip
        ftp://ftp.phprojekt.com/phprojekt.zip
        PHPProjekt Upgrade phprojekt.tar.gz
        ftp://ftp.phprojekt.com/phprojekt.tar.gz

- 漏洞信息

5292
PHProjekt filemanager_forms.php lib_path Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2004-04-09 Unknow
2004-04-09 Unknow

- 解决方案

Upgrade to version 3.1b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站