CVE-2002-0447
CVSS5.0
发布时间 :2002-07-26 00:00:00
修订时间 :2008-09-05 16:28:03
NMCOS    

[原文]Directory traversal vulnerability in Xerver Free Web Server 2.10 and earlier allows remote attackers to list arbitrary directories via a .. (dot dot) in an HTTP GET request.


[CNNVD]Xerver目录遍历漏洞(CNNVD-200207-126)

        
        Xerver是种用Java编写的免费使用的WEB Server,可运行于任何支持Java虚拟机的操作系统上,包括微软Windows、Unix/Linux变体、MacOS等等。
        由于未过滤来自URL请求的(../)序列,远程攻击者可以突破WEB根目录文访问到任何WEB Server进程有权访问的文件。值得注意的是,通常在微软平台上以SYSTEM权限运行WEB Server,意味着远程攻击者潜在可以读取任意文件。
        早期版本的Xerver可能存在同样问题。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0447
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0447
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-126
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4255
(VENDOR_ADVISORY)  BID  4255
http://www.iss.net/security_center/static/8421.php
(VENDOR_ADVISORY)  XF  xerver-dot-directory-traversal(8421)
http://archives.neohapsis.com/archives/bugtraq/2002-03/0155.html
(UNKNOWN)  BUGTRAQ  20020312 Xerver Free Web Server 2.10 file Disclosure & DoS PATCH (update version)
http://archives.neohapsis.com/archives/bugtraq/2002-03/0091.html
(UNKNOWN)  BUGTRAQ  20020308 Xerver-2.10-File-Disclousure&DoS-attack

- 漏洞信息

Xerver目录遍历漏洞
中危 输入验证
2002-07-26 00:00:00 2006-09-22 00:00:00
远程  
        
        Xerver是种用Java编写的免费使用的WEB Server,可运行于任何支持Java虚拟机的操作系统上,包括微软Windows、Unix/Linux变体、MacOS等等。
        由于未过滤来自URL请求的(../)序列,远程攻击者可以突破WEB根目录文访问到任何WEB Server进程有权访问的文件。值得注意的是,通常在微软平台上以SYSTEM权限运行WEB Server,意味着远程攻击者潜在可以读取任意文件。
        早期版本的Xerver可能存在同样问题。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有好的临时解决方法。
        厂商补丁:
        Xerver
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.javascript.nu/xerver/

- 漏洞信息

6771
Xerver Free Web Server Arbitrary Directory Listing
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Xserver contains a flaw that may lead to an unauthorized information disclosure. The issue is due to the server not properly filtering dot-dot-slash (../). By sending a specially-crafted HTTP request containing "dot dot" sequences, a remote attacker can traverse directories and view any file on the system, resulting in loss of confidentiality.

- 时间线

2002-03-08 Unknow
2002-03-08 Unknow

- 解决方案

Upgrade to version 2.20 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Xerver Directory Traversal Vulnerability
Input Validation Error 4255
Yes No
2002-03-08 12:00:00 2009-07-11 11:56:00
Discovery of this issue is credited to Alex Hernandez <al3xhernandez@ureach.com>.

- 受影响的程序版本

Xerver Xerver 2.10
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT Workstation 4.0 SP6a
- Microsoft Windows NT Workstation 4.0 SP5
- Microsoft Windows NT Workstation 4.0 SP4
- Microsoft Windows NT Workstation 4.0 SP3
- Microsoft Windows NT Workstation 4.0 SP2
- Microsoft Windows NT Workstation 4.0 SP1
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows XP Home
Xerver Xerver 2.20
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT Workstation 4.0 SP6a
- Microsoft Windows NT Workstation 4.0 SP5
- Microsoft Windows NT Workstation 4.0 SP4
- Microsoft Windows NT Workstation 4.0 SP3
- Microsoft Windows NT Workstation 4.0 SP2
- Microsoft Windows NT Workstation 4.0 SP1
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows XP Home

- 不受影响的程序版本

Xerver Xerver 2.20
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT Workstation 4.0 SP6a
- Microsoft Windows NT Workstation 4.0 SP5
- Microsoft Windows NT Workstation 4.0 SP4
- Microsoft Windows NT Workstation 4.0 SP3
- Microsoft Windows NT Workstation 4.0 SP2
- Microsoft Windows NT Workstation 4.0 SP1
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows XP Home

- 漏洞讨论

Xerver is a freely available webserver, written in Java. It will run on any operating system with Java installed, including Microsoft Windows, Unix/Linux variants, MacOS, etc.

Dot-dot-slash (../) sequences are not filtered from web requests. It is possible for a remote attacker to craft a malicious web request which is capable of breaking out of wwwroot. This has the potential to disclose arbitrary web-readable files to remote attackers.

It should be noted that webservers on Microsoft Windows operating systems normally run with SYSTEM privileges, meaning the attacker may potentially disclose the contents of any file.

This issue was reported for v2.10 of Xerver. Earlier versions may also be affected.

- 漏洞利用

This issue may be exploited with a web browser.

- 解决方案

This issue has been addressed in Xerver 2.20.


Xerver Xerver 2.10

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站