CVE-2002-0442
CVSS7.2
发布时间 :2002-07-26 00:00:00
修订时间 :2008-09-05 16:28:02
NMCO    

[原文]Buffer overflow in dlvr_audit for Caldera OpenServer 5.0.5 and 5.0.6 allows local users to gain root privileges.


[CNNVD]Caldera OpenServer dlvr_audit本地缓冲区溢出漏洞(CNNVD-200207-107)

        
        OpenServer是原先由SCO公司开发的一种商用UNIX系统,现在由Caldera公司维护。OpenServer提供了对系统监控的广泛支持。
        OperServer的监控程序实现上存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞得到主机的root权限。
        OpenServer的dlvr_audit程序用来向OpenServer的监控子系统提供监控信息,它存在缓冲区溢出漏洞,本地攻击者可以通过溢出攻击在主机上以root权限执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:caldera:openserver:5.0.6
cpe:/a:caldera:openserver:5.0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0442
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0442
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-107
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4273
(VENDOR_ADVISORY)  BID  4273
http://www.iss.net/security_center/static/8442.php
(VENDOR_ADVISORY)  XF  openserver-dlvraudit-bo(8442)
ftp://stage.caldera.com/pub/security/openserver/CSSA-2002-SCO.8/CSSA-2002-SCO.8.txt
(UNKNOWN)  CALDERA  CSSA-2002-SCO.8

- 漏洞信息

Caldera OpenServer dlvr_audit本地缓冲区溢出漏洞
高危 未知
2002-07-26 00:00:00 2005-05-02 00:00:00
本地  
        
        OpenServer是原先由SCO公司开发的一种商用UNIX系统,现在由Caldera公司维护。OpenServer提供了对系统监控的广泛支持。
        OperServer的监控程序实现上存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞得到主机的root权限。
        OpenServer的dlvr_audit程序用来向OpenServer的监控子系统提供监控信息,它存在缓冲区溢出漏洞,本地攻击者可以通过溢出攻击在主机上以root权限执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修补之前,暂时去掉dlvr_audit程序的suid位,可以使用如下命令:
        # chmod a-s /etc/auth/dlvr_audit
        厂商补丁:
        Caldera
        -------
        Caldera已经为此发布了一个安全公告(CSSA-2002-SCO.8)以及相应补丁:
        CSSA-2002-SCO.8:OpenServer: dlvr_audit: exploitable buffer overflow
        链接:ftp://stage.caldera.com/pub/security/openunix/CSSA-2002-SCO.8
        补丁下载:
        ftp.caldera.com/pub/openserver5/oss645a
        补丁安装方法:
        1. 下载映像文件OSS645A,把文件放入/tmp目录并重命名:
         mv /tmp/oss645a /tmp/VOL.000.000
        2. 用以下的命令运行软件管理器或双击桌面上的软件管理图标:
         # scoadmin software
        3. 下拉"Software"菜单选择"Install New"。
        4. 当提示要求输入从哪个主机进行安装时,选本机并且继续。
        5. 在"Select Media"菜单中,下拉"Media Device"菜单,选择"Media Images"并且继续。
        6. 当提示要求输入"Image Directory"时,输入"/tmp",选"OK"。
        7. 当要求选择需要安装的软件时,选择"OSS645A: Audit Subsystem Security Supplement",然后选取"Install"。
        8. 这样就安装完成了,选取"Host"菜单里的"Exit",就退出了安装程序。

- 漏洞信息

5291
Caldera OpenServer dlvr_audit Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站