CVE-2002-0439
CVSS7.5
发布时间 :2002-07-26 00:00:00
修订时间 :2008-09-05 16:28:01
NMCOS    

[原文]Cross-site scripting vulnerability in CaupoShop 1.30a and earlier, and possibly CaupoShopPro, allows remote attackers to execute arbitrary Javascript and steal credit card numbers or delete items by injecting the script into new customer information fields such as the message field.


[CNNVD]CaupoShop用户信息跨站脚本执行漏洞(CNNVD-200207-117)

        
        CaupoShop是一款基于WEB的电子购物系统,由PHP实现,使用在Linux,windows或者其他Unix系统平台上。
        CaupoShop对在用户信息域中的输入过滤上存在漏洞,可导致远程攻击者利用用户信息域插入Javascript代码对其他浏览用户进行跨站脚本执行攻击。
        当注册一个新的客户时,CaupoShop对用户信息域的输入没有进行过滤,攻击者可以插入恶意脚本代码,当管理员在管理域中查看客户列表的时候导致脚本代码被执行,可导致泄露用户信息,改变用户密码或者帖子等问题。
        其他早期版本也应该存在此漏洞,不过没有被证实。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0439
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0439
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-117
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4270
(PATCH)  BID  4270
http://www.iss.net/security_center/static/8431.php
(PATCH)  XF  cauposhop-user-info-css(8431)
http://www.securityfocus.com/archive/1/261218
(UNKNOWN)  BUGTRAQ  20020311 CaupoShop: cross-site-scripting bug

- 漏洞信息

CaupoShop用户信息跨站脚本执行漏洞
高危 输入验证
2002-07-26 00:00:00 2006-12-27 00:00:00
远程  
        
        CaupoShop是一款基于WEB的电子购物系统,由PHP实现,使用在Linux,windows或者其他Unix系统平台上。
        CaupoShop对在用户信息域中的输入过滤上存在漏洞,可导致远程攻击者利用用户信息域插入Javascript代码对其他浏览用户进行跨站脚本执行攻击。
        当注册一个新的客户时,CaupoShop对用户信息域的输入没有进行过滤,攻击者可以插入恶意脚本代码,当管理员在管理域中查看客户列表的时候导致脚本代码被执行,可导致泄露用户信息,改变用户密码或者帖子等问题。
        其他早期版本也应该存在此漏洞,不过没有被证实。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在浏览器设置中禁止java脚本执行可以在一定程度上减少这种漏洞造成的危害。
        厂商补丁:
        Caupo.net
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Caupo.net Upgrade CaupoShop-Classic-130-rc4.zip
        
        http://www.caupo.com/soft/download/CaupoShop-Classic-130-rc4.zip

- 漏洞信息

9279
CaupoShop New Customer Fields XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-03-11 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CaupoShop User Information Cross-Agent Scripting Vulnerability
Input Validation Error 4270
Yes No
2002-03-11 12:00:00 2009-07-11 11:56:00
Published by ppp-design <security@ppp-design.de>.

- 受影响的程序版本

Caupo.net CaupoShop 1.30 rc4
Caupo.net CaupoShop 1.30 a

- 漏洞讨论

CaupoShop is a web based shopping cart system. CaupoShop is implemented in PHP, and may be found on Linux, Windows or other Unix based systems.

A cross-agent scripting vulnerability has been reported in some versions of CaupoShop. When a user is created, JavaScript code may be included in most of the fields associated with that user. If an administrator then views the maliciously created user, the script will be displayed and interpreted in the context of the CaupoShop administration page.

This vulnerability may also exist in earlier versions of CaupoShop, or in CaupoShopPro. This has not been confirmed.

- 漏洞利用

No exploit is required.

- 解决方案

An updated version is available:


Caupo.net CaupoShop 1.30 a

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站