CVE-2002-0437
CVSS10.0
发布时间 :2002-07-26 00:00:00
修订时间 :2008-09-05 16:28:01
NMCO    

[原文]Smsd in SMS Server Tools (SMStools) before 1.4.8 allows remote attackers to execute arbitrary commands via shell metacharacters (backquotes) in message text, as described with the term "string format vulnerability" by some sources.


[CNNVD]SMS Server Tools执行任意命令漏洞(CNNVD-200207-118)

        
        SMS Server Tools是一个用来与提供SMS功能的调制解调器进行交互的软件包,它可以发送和接收文本文件,SMS服务器工具被设计工作于Linux/Unix类平台之上。
        SMS Server Tools实现上存在一些输入验证漏洞,远程攻击者可能利用这些漏洞在主机上执行任意命令。
        程序未对用户输入进行充分过滤,远程攻击者通过在输入中插入某些特定的字符,可以在主机上以SMS Server Tools进程的身份执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:stefan_frings:sms_server_tools:1.4.6
cpe:/a:stefan_frings:sms_server_tools:1.4.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0437
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0437
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-118
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4268
(VENDOR_ADVISORY)  BID  4268
http://www.iss.net/security_center/static/8433.php
(VENDOR_ADVISORY)  XF  sms-tools-format-string(8433)
http://www.isis.de/members/~s.frings/smstools/history.html
(UNKNOWN)  CONFIRM  http://www.isis.de/members/~s.frings/smstools/history.html
http://archives.neohapsis.com/archives/bugtraq/2002-03/0103.html
(UNKNOWN)  BUGTRAQ  20020311 SMStools vulnerabilities in release before 1.4.8

- 漏洞信息

SMS Server Tools执行任意命令漏洞
危急 未知
2002-07-26 00:00:00 2005-10-12 00:00:00
远程  
        
        SMS Server Tools是一个用来与提供SMS功能的调制解调器进行交互的软件包,它可以发送和接收文本文件,SMS服务器工具被设计工作于Linux/Unix类平台之上。
        SMS Server Tools实现上存在一些输入验证漏洞,远程攻击者可能利用这些漏洞在主机上执行任意命令。
        程序未对用户输入进行充分过滤,远程攻击者通过在输入中插入某些特定的字符,可以在主机上以SMS Server Tools进程的身份执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        没有合适的临时解决方法,请尽快升级到新版的软件。
        厂商补丁:
        SMS Server Tools
        ----------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.isis.de/members/~s.frings/smstools/

- 漏洞信息

5293
SMS Server Tools Smsd Arbitrary Command Execution
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-03-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站