CVE-2002-0417
CVSS5.0
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:27:58
NMCOS    

[原文]Directory traversal vulnerability in Endymion MailMan before 3.1 allows remote attackers to read arbitrary files via a .. (dot dot) and a null character in the ALTERNATE_TEMPLATES parameter for various mmstdo*.cgi programs.


[CNNVD]Endymion MailMan 预备模板变量使文件泄露漏洞(CNNVD-200208-187)

        
        Endymion MailMan是一款基于WEB的邮件应用程序,运行在多种Unix和Linux系统平台下,也可运行于Windows平台下,由PERL脚本语言实现。
        Endymion MailMan实现上存在输入验证漏洞,可导致任意文件内容被泄露问题。
        由于Endymion MailMan对用户提交给ALTERNATE_TEMPLATES CGI 变量的输入没有过滤,导致程序存在目录遍历问题,远程攻击者可以通过提交包含连续(../)并在请求文件名后追加NULL字符(%00)的HTTP请求,可导致突破wwwroot目录限制并以MailMan的权限读取目标系统上的任意文件内容。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:endymion:mailman_webmail:3.0.11
cpe:/a:endymion:mailman_webmail:3.0.35
cpe:/a:endymion:mailman_webmail:3.0.15
cpe:/a:endymion:mailman_webmail:3.0.6
cpe:/a:endymion:mailman_webmail:3.0.33
cpe:/a:endymion:mailman_webmail:3.0.19
cpe:/a:endymion:mailman_webmail:3.0.22
cpe:/a:endymion:mailman_webmail:3.0.31
cpe:/a:endymion:mailman_webmail:3.0.24
cpe:/a:endymion:mailman_webmail:3.0.2
cpe:/a:endymion:mailman_webmail:3.0.18
cpe:/a:endymion:mailman_webmail:3.0.23
cpe:/a:endymion:mailman_webmail:3.0.30
cpe:/a:endymion:mailman_webmail:3.0.29
cpe:/a:endymion:mailman_webmail:3.0.26
cpe:/a:endymion:mailman_webmail:3.0.20
cpe:/a:endymion:mailman_webmail:3.0.8
cpe:/a:endymion:mailman_webmail:3.0.7
cpe:/a:endymion:mailman_webmail:3.0.10
cpe:/a:endymion:mailman_webmail:3.0.4
cpe:/a:endymion:mailman_webmail:3.0.21
cpe:/a:endymion:mailman_webmail:3.0.27
cpe:/a:endymion:mailman_webmail:3.0.14
cpe:/a:endymion:mailman_webmail:3.0.34
cpe:/a:endymion:mailman_webmail:3.0.32
cpe:/a:endymion:mailman_webmail:3.0.13
cpe:/a:endymion:mailman_webmail:3.0.28
cpe:/a:endymion:mailman_webmail:3.0.16
cpe:/a:endymion:mailman_webmail:3.0
cpe:/a:endymion:mailman_webmail:3.0.12
cpe:/a:endymion:mailman_webmail:3.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0417
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0417
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-187
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4222
(VENDOR_ADVISORY)  BID  4222
http://www.iss.net/security_center/static/8357.php
(VENDOR_ADVISORY)  XF  mailman-alternate-templates-traversal(8357)
http://www.endymion.com/products/mailman/history.htm
(UNKNOWN)  CONFIRM  http://www.endymion.com/products/mailman/history.htm
http://online.securityfocus.com/archive/1/259730
(VENDOR_ADVISORY)  BUGTRAQ  20020305 Endymion SakeMail and MailMan File Disclosure Vulnerability

- 漏洞信息

Endymion MailMan 预备模板变量使文件泄露漏洞
中危 输入验证
2002-08-12 00:00:00 2006-09-20 00:00:00
远程  
        
        Endymion MailMan是一款基于WEB的邮件应用程序,运行在多种Unix和Linux系统平台下,也可运行于Windows平台下,由PERL脚本语言实现。
        Endymion MailMan实现上存在输入验证漏洞,可导致任意文件内容被泄露问题。
        由于Endymion MailMan对用户提交给ALTERNATE_TEMPLATES CGI 变量的输入没有过滤,导致程序存在目录遍历问题,远程攻击者可以通过提交包含连续(../)并在请求文件名后追加NULL字符(%00)的HTTP请求,可导致突破wwwroot目录限制并以MailMan的权限读取目标系统上的任意文件内容。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修补之前,暂时停止此程序的使用。
        厂商补丁:
        Endymion
        --------
        目前厂商已经已经在新版本的软件中修复了这个安全问题,请到厂商的主页下载:
        
        http://www.endymion.com/products/mailman/download.htm

- 漏洞信息

6770
Endymion MailMan Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

Mailman Webmail contains a flaw that allows a remote attacker to navigate outside of the web path. The issue is due to the mmstdo.cgi not properly sanitizing user input, specifically traversal style attacks (../../) followed by a trailing null character (%00) via the ALTERNATE_TEMPLATES CGI variable.

- 时间线

2002-03-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Endymion MailMan Alternate Templates File Disclosure Vulnerability
Input Validation Error 4222
Yes No
2002-03-04 12:00:00 2009-07-11 10:56:00
Discovery of this issue is credited to Rudi Carrell.

- 受影响的程序版本

Endymion MailMan WebMail 3.0.35
Endymion MailMan WebMail 3.0.34
Endymion MailMan WebMail 3.0.33
Endymion MailMan WebMail 3.0.32
Endymion MailMan WebMail 3.0.31
Endymion MailMan WebMail 3.0.30
Endymion MailMan WebMail 3.0.29
Endymion MailMan WebMail 3.0.28
Endymion MailMan WebMail 3.0.27
Endymion MailMan WebMail 3.0.26
Endymion MailMan WebMail 3.0.25
Endymion MailMan WebMail 3.0.24
Endymion MailMan WebMail 3.0.23
Endymion MailMan WebMail 3.0.22
Endymion MailMan WebMail 3.0.21
Endymion MailMan WebMail 3.0.20
Endymion MailMan WebMail 3.0.19
Endymion MailMan WebMail 3.0.18
Endymion MailMan WebMail 3.0.16
Endymion MailMan WebMail 3.0.15
Endymion MailMan WebMail 3.0.14
Endymion MailMan WebMail 3.0.13
Endymion MailMan WebMail 3.0.12
Endymion MailMan WebMail 3.0.11
Endymion MailMan WebMail 3.0.10
Endymion MailMan WebMail 3.0.8
Endymion MailMan WebMail 3.0.7
Endymion MailMan WebMail 3.0.6
Endymion MailMan WebMail 3.0.4
Endymion MailMan WebMail 3.0.1
Endymion MailMan WebMail 3.0
Endymion MailMan WebMail 3.1

- 不受影响的程序版本

Endymion MailMan WebMail 3.1

- 漏洞讨论

Endymion MailMan is a webmail application written in Perl. It will run on most Linux and Unix variants, in addition to Microsoft Windows operating systems.

Due to insufficient validation of input supplied to the ALTERNATE_TEMPLATES CGI variable, Endymion MailMan is prone to directory traversal attacks. An attacker may view arbitrary web-readable files by crafting a malicious web request containing dot-dot-slash (../) sequences, followed by the name of the requested file, followed by a trailing null character (%00).

This issue may cause sensitive information to be disclosed to remote attackers.

- 漏洞利用

This issue may be exploited with a web browser.

- 解决方案

This issue has been addressed in version 3.1. Affected users are advised to upgrade.


Endymion MailMan WebMail 3.0

Endymion MailMan WebMail 3.0.1

Endymion MailMan WebMail 3.0.10

Endymion MailMan WebMail 3.0.11

Endymion MailMan WebMail 3.0.12

Endymion MailMan WebMail 3.0.13

Endymion MailMan WebMail 3.0.14

Endymion MailMan WebMail 3.0.15

Endymion MailMan WebMail 3.0.16

Endymion MailMan WebMail 3.0.18

Endymion MailMan WebMail 3.0.19

Endymion MailMan WebMail 3.0.20

Endymion MailMan WebMail 3.0.21

Endymion MailMan WebMail 3.0.22

Endymion MailMan WebMail 3.0.23

Endymion MailMan WebMail 3.0.24

Endymion MailMan WebMail 3.0.25

Endymion MailMan WebMail 3.0.26

Endymion MailMan WebMail 3.0.27

Endymion MailMan WebMail 3.0.28

Endymion MailMan WebMail 3.0.29

Endymion MailMan WebMail 3.0.30

Endymion MailMan WebMail 3.0.31

Endymion MailMan WebMail 3.0.32

Endymion MailMan WebMail 3.0.33

Endymion MailMan WebMail 3.0.34

Endymion MailMan WebMail 3.0.35

Endymion MailMan WebMail 3.0.4

Endymion MailMan WebMail 3.0.6

Endymion MailMan WebMail 3.0.7

Endymion MailMan WebMail 3.0.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站