CVE-2002-0413
CVSS7.5
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:27:57
NMCOES    

[原文]Cross-site scripting vulnerability in ReBB allows remote attackers to execute arbitrary Javascript and steal cookies via an IMG tag whose URL includes the malicious script.


[CNNVD]ReBB Image标记跨站脚本执行漏洞(CNNVD-200208-231)

        
        ReBB是一款基于WEB的论坛程序,运行在多种Unix和Linux系统平台下,也可运行于Windows平台下,由PHP实现并可用多种数据库平台支持。
        ReBB对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        ReBB支持在帖子中用户使用[img]/[/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0413
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0413
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-231
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4220
(VENDOR_ADVISORY)  BID  4220
http://www.iss.net/security_center/static/8353.php
(VENDOR_ADVISORY)  XF  rebb-img-css(8353)
http://online.securityfocus.com/archive/1/259464
(VENDOR_ADVISORY)  BUGTRAQ  20020304 ReBB javascripts vulnerability

- 漏洞信息

ReBB Image标记跨站脚本执行漏洞
高危 输入验证
2002-08-12 00:00:00 2005-10-20 00:00:00
远程  
        
        ReBB是一款基于WEB的论坛程序,运行在多种Unix和Linux系统平台下,也可运行于Windows平台下,由PHP实现并可用多种数据库平台支持。
        ReBB对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        ReBB支持在帖子中用户使用[img]/[/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时关闭Image标记的使用。
        厂商补丁:
        ReBB
        ----
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.rebb.net/

- 漏洞信息 (21312)

ReBB 1.0 Image Tag Cross-Agent Scripting Vulnerability (EDBID:21312)
php webapps
2002-03-04 Verified
0 skizzik
N/A [点击下载]
source: http://www.securityfocus.com/bid/4220/info

ReBB is web forum software which will run on most Unix and Linux variants, as well as Microsoft Windows operating systems. It is written in PHP and may be back-ended by a number of databases.

ReBB allows users to include images in forum messages using image tags, with the following syntax:

[img]url of image[/img]

It is possible to inject arbitrary script code into forum messages via these image tags. Script code will be executed in the browser of the user viewing the forum message, in the context of the website running the vulnerable software. This may allow an attacker to steal cookie-based authentication credentials. 

[img]javascript:alert('test')[/img] 		

- 漏洞信息

9280
ReBB IMG Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Third-party Verified, Uncoordinated Disclosure

- 漏洞描述

- 时间线

2002-03-04 Unknow
2002-03-04 Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

ReBB Image Tag Cross-Agent Scripting Vulnerability
Input Validation Error 4220
Yes No
2002-03-04 12:00:00 2009-07-11 10:56:00
This issue was reported to BugTraq by <skizzik@imail.ru>.

- 受影响的程序版本

ReBB ReBB 1.0

- 漏洞讨论

ReBB is web forum software which will run on most Unix and Linux variants, as well as Microsoft Windows operating systems. It is written in PHP and may be back-ended by a number of databases.

ReBB allows users to include images in forum messages using image tags, with the following syntax:

[img]url of image[/img]

It is possible to inject arbitrary script code into forum messages via these image tags. Script code will be executed in the browser of the user viewing the forum message, in the context of the website running the vulnerable software. This may allow an attacker to steal cookie-based authentication credentials.

- 漏洞利用

This condition may be reproduced with the following example:

[img]javascript:alert('test')[/img]

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站