CVE-2002-0404
CVSS5.0
发布时间 :2002-06-18 00:00:00
修订时间 :2016-10-17 22:20:09
NMCO    

[原文]Vulnerability in GIOP dissector in Ethereal before 0.9.3 allows remote attackers to cause a denial of service (memory consumption).


[CNNVD]Ethereal GIOP解析器远程内存耗竭拒绝服务攻击漏洞(CNNVD-200206-041)

        
        Ethereal是一款免费开放源代码的网络协议分析程序,可使用在Unix和Windows操作系统下。
        Ethereal中的GIOP解析器在处理不正常信息包时存在漏洞,可导致远程攻击者进行拒绝服务攻击。
        Ethereal中的GIOP解析器是解码General Inter-ORB Protocol(GIOP)协议的机制,攻击者可以构建畸形的信息包并提交给有Ethereal监听的网络中,可导致Ethereal分配大量的内容而使系统产生拒绝服务攻击。
        <*链接:http://www.ethereal.com/appnotes/enpa-sa-00004.html
         http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000505
         http://www.caldera.com/support/security/advisories/CSSA-2002-037.0.txt
        *>

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ethereal_group:ethereal:0.9.2
cpe:/a:ethereal_group:ethereal:0.9.1
cpe:/a:ethereal_group:ethereal:0.9_.0
cpe:/a:ethereal_group:ethereal:0.9.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0404
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0404
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-041
(官方数据源) CNNVD

- 其它链接及资源

ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2002-037.0.txt
(UNKNOWN)  CALDERA  CSSA-2002-037.0
http://distro.conectiva.com/atualizacoes/?id=a&anuncio=000505
(UNKNOWN)  CONECTIVA  CLSA-2002:505
http://marc.info/?l=bugtraq&m=102268626526119&w=2
(UNKNOWN)  BUGTRAQ  20020529 Potential security issues in Ethereal
http://www.debian.org/security/2002/dsa-130
(VENDOR_ADVISORY)  DEBIAN  DSA-130
http://www.ethereal.com/appnotes/enpa-sa-00004.html
(VENDOR_ADVISORY)  CONFIRM  http://www.ethereal.com/appnotes/enpa-sa-00004.html
http://www.iss.net/security_center/static/9206.php
(UNKNOWN)  XF  ethereal-giop-dissector-dos(9206)
http://www.redhat.com/support/errata/RHSA-2002-036.html
(UNKNOWN)  REDHAT  RHSA-2002:036
http://www.redhat.com/support/errata/RHSA-2002-088.html
(UNKNOWN)  REDHAT  RHSA-2002:088
http://www.redhat.com/support/errata/RHSA-2002-170.html
(UNKNOWN)  REDHAT  RHSA-2002:170
http://www.securityfocus.com/bid/4808
(UNKNOWN)  BID  4808

- 漏洞信息

Ethereal GIOP解析器远程内存耗竭拒绝服务攻击漏洞
中危 其他
2002-06-18 00:00:00 2006-09-05 00:00:00
远程  
        
        Ethereal是一款免费开放源代码的网络协议分析程序,可使用在Unix和Windows操作系统下。
        Ethereal中的GIOP解析器在处理不正常信息包时存在漏洞,可导致远程攻击者进行拒绝服务攻击。
        Ethereal中的GIOP解析器是解码General Inter-ORB Protocol(GIOP)协议的机制,攻击者可以构建畸形的信息包并提交给有Ethereal监听的网络中,可导致Ethereal分配大量的内容而使系统产生拒绝服务攻击。
        <*链接:http://www.ethereal.com/appnotes/enpa-sa-00004.html
         http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000505
         http://www.caldera.com/support/security/advisories/CSSA-2002-037.0.txt
        *>

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 关闭有漏洞的解析器。
        厂商补丁:
        Caldera
        -------
        Caldera已经为此发布了一个安全公告(CSSA-2002-037.0)以及相应补丁:
        CSSA-2002-037.0:Linux: various packet handling vunerabilities in ethereal
        链接:
        http://www.caldera.com/support/security/advisories/CSSA-2002-037.0.txt

        补丁下载:
        SCO RPM ethereal-0.9.4-1.i386.rpm
        ftp://ftp.sco.com/pub/updates/OpenLinux/3.1.1/Server/CSSA-2002-037.0/RPMS/ethereal-0.9.4-1.i386.rpm
        SCO RPM ethereal-0.9.4-1.i386.rpm
        ftp://ftp.sco.com/pub/updates/OpenLinux/3.1.1/Workstation/CSSA-2002-037.0/RPMS/ethereal-0.9.4-1.i386.rpm
        SCO RPM ethereal-0.9.4-1.i386.rpm
        ftp://ftp.sco.com/pub/updates/OpenLinux/3.1/Server/CSSA-2002-037.0/RPMS/ethereal-0.9.4-1.i386.rpm
        SCO RPM ethereal-0.9.4-1.i386.rpm
        ftp://ftp.sco.com/pub/updates/OpenLinux/3.1/Workstation/CSSA-2002-037.0/RPMS/ethereal-0.9.4-1.i386.rpm
        Conectiva
        ---------
        Conectiva已经为此发布了一个安全公告(CLA-2002:505)以及相应补丁:
        CLA-2002:505:ethereal
        链接:
        http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000505

        补丁下载:
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/ethereal-0.9.5-1U60_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/SRPMS/ethereal-0.9.5-1U60_1cl.src.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/ethereal-0.9.5-1U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/SRPMS/ethereal-0.9.5-1U70_1cl.src.rpm
        ftp://atualizacoes.conectiva.com.br/8/RPMS/ethereal-0.9.5-1U8_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/8/RPMS/ethereal-common-0.9.5-1U8_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/8/RPMS/ethereal-gtk-0.9.5-1U8_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/8/RPMS/ethereal-utils-0.9.5-1U8_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/8/RPMS/tethereal-0.9.5-1U8_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/8/SRPMS/ethereal-0.9.5-1U8_2cl.src.rpm
        Conectiva Linux version 6.0及以上版本的用户可以使用apt进行RPM包的更新:
        - 把以下的文本行加入到/etc/apt/sources.list文件中:
        
        rpm [cncbr] ftp://atualizacoes.conectiva.com.br 6.0/conectiva updates
        (如果你不是使用6.0版本,用合适的版本号代替上面的6.0)
        - 执行: apt-get update
        - 更新以后,再执行: apt-get upgrade
        Ethereal Group
        --------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Ethereal Group Ethereal 0.9 .0:
        Ethereal Group Upgrade ethereal-0.9.4.tar.gz
        
        http://www.ethereal.com/distribution/ethereal-0.9.4.tar.gz

        Ethereal Group Ethereal 0.9.1:
        Ethereal Group Upgrade ethereal-0.9.4.tar.gz
        
        http://www.ethereal.com/distribution/ethereal-0.9.4.tar.gz

        Ethereal Group Ethereal 0.9.2:
        Ethereal Group Upgrade ethereal-0.9.4.tar.gz
        
        http://www.ethereal.com/distribution/ethereal-0.9.4.tar.gz

        Ethereal Group Ethereal 0.9.3:
        Ethereal Group Upgrade ethereal-0.9.4.tar.gz
        
        http://www.ethereal.com/distribution/ethereal-0.9.4.tar.gz

- 漏洞信息

4484
Ethereal GIOP Dissector Memory Exhaustion DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-05-19 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站