CVE-2002-0330
CVSS7.5
发布时间 :2002-06-25 00:00:00
修订时间 :2016-10-17 22:19:17
NMCOE    

[原文]Cross-site scripting vulnerability in codeparse.php of Open Bulletin Board (OpenBB) 1.0.0 allows remote attackers to execute arbitrary script and steal cookies via Javascript in the IMG tag.


[CNNVD]OpenBB Image标记跨站脚本执行漏洞(CNNVD-200206-073)

        
        OpenBB是一个基于Web的论坛程序,用PHP实现,可运行于Unix类操作系统下,也可运行于Windows平台。
        OpenBB对用户输入过滤上存在漏洞,可能使远程攻击者利用在论坛上的发贴对其他用户进行跨站脚本执行攻击。
        OpenBB支持用户在贴子中使用[img]标记插入图像,但它未对标记中的内容做充分的过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当用户浏览相关页面时,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于Cookie的认证信息。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:openbb:openbb:1.0.0_beta1
cpe:/a:openbb:openbb:1.0.0_rc2
cpe:/a:openbb:openbb:1.0.0_rc1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0330
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0330
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-073
(官方数据源) CNNVD

- 其它链接及资源

http://community.iansoft.net/read.php?TID=5159
(UNKNOWN)  CONFIRM  http://community.iansoft.net/read.php?TID=5159
http://marc.info/?l=bugtraq&m=101466092601554&w=2
(UNKNOWN)  BUGTRAQ  20020225 Open Bulletin Board javascript bug.
http://www.iss.net/security_center/static/8278.php
(VENDOR_ADVISORY)  XF  openbb-img-css(8278)
http://www.securityfocus.com/bid/4171
(UNKNOWN)  BID  4171

- 漏洞信息

OpenBB Image标记跨站脚本执行漏洞
高危 输入验证
2002-06-25 00:00:00 2005-05-02 00:00:00
远程  
        
        OpenBB是一个基于Web的论坛程序,用PHP实现,可运行于Unix类操作系统下,也可运行于Windows平台。
        OpenBB对用户输入过滤上存在漏洞,可能使远程攻击者利用在论坛上的发贴对其他用户进行跨站脚本执行攻击。
        OpenBB支持用户在贴子中使用[img]标记插入图像,但它未对标记中的内容做充分的过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当用户浏览相关页面时,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于Cookie的认证信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修复之前暂时关闭Image标记的使用。
        厂商补丁:
        Iansoft
        -------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.openbb.net/

- 漏洞信息 (21301)

OpenBB 1.0.x Image Tag Cross-Agent Scripting Vulnerability (EDBID:21301)
php webapps
2002-02-25 Verified
0 skizzik
N/A [点击下载]
source: http://www.securityfocus.com/bid/4171/info

OpenBB is web forum software written in PHP. It will run on most Linux and Unix variants, in addition to Microsoft Windows operating systems.

OpenBB allows users to include images in forum messages using image tags, with the following syntax:

[img]url of image[/img]

It is possible to inject arbitrary script code into forum messages via these image tags. Script code will be executed in the browser of the user viewing the forum message, in the context of the website running the vulnerable software. This may allow an attacker to steal cookie-based authentication credentials.

[img]javasCript:alert('Hello world.')[/img] 
  			

- 漏洞信息 (21474)

OpenBB 1.0 .0 RC3 BBCode Cross Agent HTML Injection Vulnerability (EDBID:21474)
php webapps
2002-05-24 Verified
0 frog
N/A [点击下载]
source: http://www.securityfocus.com/bid/4819/info

OpenBB is web forum software written in PHP. It will run on most Linux and Unix variants, in addition to Microsoft Windows operating systems.

OpenBB is reportedly vulnerable to HTML injection attacks. The vulnerability occurs when HTML code is replaced with BBCodes.

OpenBB uses 'BBCodes' in the place of HTML code to include images, links etc. However, HTML tags are not adequately replaced from with BBCodes. It is possible to inject arbitrary HTML code into forum messages. As a result, OpenBB is prone to cross-agent scripting attacks. Script code will be executed in the browser of the user viewing the forum message and may allow an attacker to steal cookie-based authentication credentials. 

[ img]http:// " onerror="ANYSCRIPT"[/img ] 		

- 漏洞信息

5320
OpenBB codeparse.php Multiple Method XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

OpenBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'IMG' or 'glow' tags upon submission to the 'codeparse.php' script, or the 'box' parameter upon submission to the 'myhome.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-02-25 Unknow
2002-02-25 Unknow

- 解决方案

Upgrade to version 1.0.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站