CVE-2002-0328
CVSS7.5
发布时间 :2002-06-25 00:00:00
修订时间 :2016-10-17 22:19:14
NMCOES    

[原文]Cross-site scripting vulnerability in Ikonboard 3.0.1 allows remote attackers to execute arbitrary script as other Ikonboard users and steal cookies via Javascript in an IMG tag.


[CNNVD]Ikonboard图像标签跨代理脚本漏洞(CNNVD-200206-091)

        Ikonboard 3.0.1版本存在跨站脚本漏洞。远程攻击者可以像其他Ikonboard用户借助IMG标签中的Javascript执行任意脚本以及窃取cookie。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ikonboard.com:ikonboard:2.17
cpe:/a:ikonboard.com:ikonboard:3.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0328
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0328
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-091
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=101475420818274&w=2
(UNKNOWN)  BUGTRAQ  20020226 Re: Open Bulletin Board javascript bug.
http://www.securityfocus.com/bid/4182
(UNKNOWN)  BID  4182

- 漏洞信息

Ikonboard图像标签跨代理脚本漏洞
高危 跨站脚本
2002-06-25 00:00:00 2005-10-20 00:00:00
远程  
        Ikonboard 3.0.1版本存在跨站脚本漏洞。远程攻击者可以像其他Ikonboard用户借助IMG标签中的Javascript执行任意脚本以及窃取cookie。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (21304)

Ikonboard 2.17/3.0/3.1 Image Tag Cross-Agent Scripting Vulnerability (EDBID:21304)
php webapps
2002-02-26 Verified
0 godminus
N/A [点击下载]
source: http://www.securityfocus.com/bid/4182/info

Ikonboard is a Web Bulletin Board Service (BBS) software package written in Perl which runs on Unix and Linux variants.

Ikonboard allows users to include images in forum messages using image tags, with the following syntax:

[img]url of image[/img]

It is possible to inject arbitrary script code into forum messages via these image tags. Script code will be executed in the browser of the user viewing the forum message, in the context of the website running the vulnerable software. This may allow an attacker to steal cookie-based authentication credentials.

Reports have indicated that this may be an issue in older versions.

It has also been reported that Ikonboard 3.1.1 is also vulnerable to this issue.

[img]javasCript:alert('Hello world.')[/img]
[IMG]javascript:alert(document.cookie).gif[/IMG] 		

- 漏洞信息

9002
Ikonboard IMG Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Third-party Verified

- 漏洞描述

- 时间线

2002-03-19 Unknow
2002-03-19 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Ikonboard Image Tag Cross-Agent Scripting Vulnerability
Input Validation Error 4182
Yes No
2002-02-26 12:00:00 2009-07-11 10:56:00
This vulnerability was reported to BugTraq by godminus <godminus@owns.com>.

- 受影响的程序版本

Ikonboard.com ikonboard 3.1.1
Ikonboard.com ikonboard 3.0 .1
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
Ikonboard.com ikonboard 2.17

- 漏洞讨论

Ikonboard is a Web Bulletin Board Service (BBS) software package written in Perl which runs on Unix and Linux variants.

Ikonboard allows users to include images in forum messages using image tags, with the following syntax:

[img]url of image[/img]

It is possible to inject arbitrary script code into forum messages via these image tags. Script code will be executed in the browser of the user viewing the forum message, in the context of the website running the vulnerable software. This may allow an attacker to steal cookie-based authentication credentials.

Reports have indicated that this may be an issue in older versions.

It has also been reported that Ikonboard 3.1.1 is also vulnerable to this issue.

- 漏洞利用

The following examples should reproduce this condition:

[img]javasCript:alert('Hello world.')[/img]
[IMG]javascript:alert(document.cookie).gif[/IMG]

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站