CVE-2002-0319
CVSS7.5
发布时间 :2002-06-25 00:00:00
修订时间 :2016-10-17 22:19:03
NMCOES    

[原文]Cross-site scripting vulnerability in edituser.php for pforum 1.14 and earlier allows remote attackers to execute script and steal cookies from other users via Javascript in a username.


[CNNVD]Powie PForum Username跨站执行脚本漏洞(CNNVD-200206-088)

        
        Powie PForum是采用PHP和MySQL实现的WWW论坛,可运行于绝大多数Unix/Linux变体以及微软Windows操作系统。
        PForum易受跨站执行脚本攻击。
        尽管作者试图过滤来自URL请求的恶意代码,但它忘记检查username参数了。比如攻击者设法使受害者访问如下URL
        test@test.com&pwd=test&pwd2=test&filled=1" target="_blank">http://www.server.com/pforum/edituser.php?boardid=&agree=1&username=%3Cscript%3Ealert(document.cookie)%3C/script%3E&nickname=test&email=test@test.com&pwd=test&pwd2=test&filled=1
        其中的Java Script代码得到执行。这种办法潜在导致合法用户用于身份验证的cookie被非法窃取。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:powie:pforum:1.11
cpe:/a:powie:pforum:1.14
cpe:/a:powie:pforum:1.12
cpe:/a:powie:pforum:1.13

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0319
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0319
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-088
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=101446366708757&w=2
(UNKNOWN)  BUGTRAQ  20020222 pforum: cross-site-scripting bug
http://www.iss.net/security_center/static/8263.php
(VENDOR_ADVISORY)  XF  pforum-username-css(8263)
http://www.securityfocus.com/bid/4165
(VENDOR_ADVISORY)  BID  4165

- 漏洞信息

Powie PForum Username跨站执行脚本漏洞
高危 输入验证
2002-06-25 00:00:00 2005-10-20 00:00:00
远程  
        
        Powie PForum是采用PHP和MySQL实现的WWW论坛,可运行于绝大多数Unix/Linux变体以及微软Windows操作系统。
        PForum易受跨站执行脚本攻击。
        尽管作者试图过滤来自URL请求的恶意代码,但它忘记检查username参数了。比如攻击者设法使受害者访问如下URL
        test@test.com&pwd=test&pwd2=test&filled=1" target="_blank">http://www.server.com/pforum/edituser.php?boardid=&agree=1&username=%3Cscript%3Ealert(document.cookie)%3C/script%3E&nickname=test&email=test@test.com&pwd=test&pwd2=test&filled=1
        其中的Java Script代码得到执行。这种办法潜在导致合法用户用于身份验证的cookie被非法窃取。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 没有合适的临时解决方法,请升级到软件的新版本。
        厂商补丁:
        Powie
        -----
        目前厂商已经在1.15版本的软件中修复了这个安全问题,请到厂商的主页下载:
        
        http://www.powie.de/pm/pmagic.php?pmagic=pforum

- 漏洞信息 (21299)

Powie PForum 1.1x Username Cross-Site Scripting Vulnerability (EDBID:21299)
php webapps
2002-02-22 Verified
0 Jens Liebchen
N/A [点击下载]
source: http://www.securityfocus.com/bid/4165/info

Powie PForum is web forum software, written in PHP and back-ended by MySQL. It will run on most Unix and Linux variants, as well as Microsoft Windows operating systems.

PForum is prone to cross-site scripting attacks. It is possible for an attacker to construct a malicious link which includes arbitrary script code. In particular, the username URL parameter does not filter variations of HTML tags. A legitimate user who browses the malicious link will have the attacker-supplied script code executed in their browser, in their context of the website running the vulnerable software.

This may enable an attacker to steal cookie-based authentication credentials from the legitimate user. 

http://www.server.com/pforum/edituser.php?boardid=&agree=1
&username=%3Cscript%3Ealert(document.cookie)%3C/script%3E
&nickname=test&email=test@test.com&pwd=test&pwd2=test&filled=1 		

- 漏洞信息

9285
Powie's PSCRIPT Forum edituser.php Username Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Third-party Verified

- 漏洞描述

Pforum contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "username" parameter upon submission to the "edituser.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-02-22 Unknow
2002-02-22 Unknow

- 解决方案

Upgrade to version 1.15 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Powie PForum Username Cross-Site Scripting Vulnerability
Input Validation Error 4165
Yes No
2002-02-22 12:00:00 2009-07-11 10:56:00
This vulnerability was submitted to BugTraq on February 22nd, 2002 by Jens Liebchen <security@ppp-design.de>.

- 受影响的程序版本

Powie PForum 1.14
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
Powie PForum 1.13
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
Powie PForum 1.12
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
Powie PForum 1.11
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
Powie PForum 1.15
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17

- 不受影响的程序版本

Powie PForum 1.15
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17

- 漏洞讨论

Powie PForum is web forum software, written in PHP and back-ended by MySQL. It will run on most Unix and Linux variants, as well as Microsoft Windows operating systems.

PForum is prone to cross-site scripting attacks. It is possible for an attacker to construct a malicious link which includes arbitrary script code. In particular, the username URL parameter does not filter variations of HTML tags. A legitimate user who browses the malicious link will have the attacker-supplied script code executed in their browser, in their context of the website running the vulnerable software.

This may enable an attacker to steal cookie-based authentication credentials from the legitimate user.

- 漏洞利用

The following example was provided:

http://www.server.com/pforum/edituser.php?boardid=&amp;agree=1
&amp;username=%3Cscript%3Ealert(document.cookie)%3C/script%3E
&amp;nickname=test&amp;email=test@test.com&amp;pwd=test&amp;pwd2=test&amp;filled=1

- 解决方案

This issue has been addressed in version 1.15 of the software.


Powie PForum 1.11

Powie PForum 1.12

Powie PForum 1.13

Powie PForum 1.14

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站