CVE-2002-0247
CVSS7.2
发布时间 :2002-05-29 00:00:00
修订时间 :2008-09-10 20:00:47
NMCOS    

[原文]Buffer overflows in wmtv 0.6.5 and earlier may allow local users to gain privileges.


[CNNVD]RedHat Linux TTY层内核错误拒绝服务攻击漏洞(CNNVD-200205-053)

        
        RedHat是一款免费开放源代码的Linux操作系统。
        RedHat Linux TTY层存在漏洞,本地攻击者可以利用这个漏洞对内核进行破坏,可能导致系统崩溃。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0247
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0247
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200205-053
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/8111.php
(VENDOR_ADVISORY)  XF  wmtv-local-bo(8111)
http://www.debian.org/security/2002/dsa-108
(VENDOR_ADVISORY)  DEBIAN  DSA-108
http://www.securityfocus.com/bid/4054
(UNKNOWN)  BID  4054

- 漏洞信息

RedHat Linux TTY层内核错误拒绝服务攻击漏洞
高危 边界条件错误
2002-05-29 00:00:00 2005-10-20 00:00:00
本地  
        
        RedHat是一款免费开放源代码的Linux操作系统。
        RedHat Linux TTY层存在漏洞,本地攻击者可以利用这个漏洞对内核进行破坏,可能导致系统崩溃。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2003:187-01)以及相应补丁:
        RHSA-2003:187-01:Updated 2.4 kernel fixes vulnerabilities and driver bugs
        链接:https://www.redhat.com/support/errata/RHSA-2003-187.html
        补丁下载:
        Red Hat Linux 7.1:
        SRPMS:
        ftp://updates.redhat.com/7.1/en/os/SRPMS/kernel-2.4.20-18.7.src.rpm
        ftp://updates.redhat.com/7.1/en/os/SRPMS/quota-3.06-9.71.src.rpm
        athlon:
        ftp://updates.redhat.com/7.1/en/os/athlon/kernel-2.4.20-18.7.athlon.rpm
        ftp://updates.redhat.com/7.1/en/os/athlon/kernel-smp-2.4.20-18.7.athlon.rpm
        i386:
        ftp://updates.redhat.com/7.1/en/os/i386/kernel-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.1/en/os/i386/kernel-source-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.1/en/os/i386/kernel-doc-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.1/en/os/i386/kernel-BOOT-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.1/en/os/i386/quota-3.06-9.71.i386.rpm
        i586:
        ftp://updates.redhat.com/7.1/en/os/i586/kernel-2.4.20-18.7.i586.rpm
        ftp://updates.redhat.com/7.1/en/os/i586/kernel-smp-2.4.20-18.7.i586.rpm
        i686:
        ftp://updates.redhat.com/7.1/en/os/i686/kernel-2.4.20-18.7.i686.rpm
        ftp://updates.redhat.com/7.1/en/os/i686/kernel-smp-2.4.20-18.7.i686.rpm
        ftp://updates.redhat.com/7.1/en/os/i686/kernel-bigmem-2.4.20-18.7.i686.rpm
        Red Hat Linux 7.2:
        SRPMS:
        ftp://updates.redhat.com/7.2/en/os/SRPMS/kernel-2.4.20-18.7.src.rpm
        ftp://updates.redhat.com/7.2/en/os/SRPMS/quota-3.06-9.7.src.rpm
        athlon:
        ftp://updates.redhat.com/7.2/en/os/athlon/kernel-2.4.20-18.7.athlon.rpm
        ftp://updates.redhat.com/7.2/en/os/athlon/kernel-smp-2.4.20-18.7.athlon.rpm
        i386:
        ftp://updates.redhat.com/7.2/en/os/i386/kernel-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.2/en/os/i386/kernel-source-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.2/en/os/i386/kernel-doc-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.2/en/os/i386/kernel-BOOT-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.2/en/os/i386/quota-3.06-9.7.i386.rpm
        i586:
        ftp://updates.redhat.com/7.2/en/os/i586/kernel-2.4.20-18.7.i586.rpm
        ftp://updates.redhat.com/7.2/en/os/i586/kernel-smp-2.4.20-18.7.i586.rpm
        i686:
        ftp://updates.redhat.com/7.2/en/os/i686/kernel-2.4.20-18.7.i686.rpm
        ftp://updates.redhat.com/7.2/en/os/i686/kernel-smp-2.4.20-18.7.i686.rpm
        ftp://updates.redhat.com/7.2/en/os/i686/kernel-bigmem-2.4.20-18.7.i686.rpm
        Red Hat Linux 7.3:
        SRPMS:
        ftp://updates.redhat.com/7.3/en/os/SRPMS/kernel-2.4.20-18.7.src.rpm
        ftp://updates.redhat.com/7.3/en/os/SRPMS/quota-3.06-9.7.src.rpm
        athlon:
        ftp://updates.redhat.com/7.3/en/os/athlon/kernel-2.4.20-18.7.athlon.rpm
        ftp://updates.redhat.com/7.3/en/os/athlon/kernel-smp-2.4.20-18.7.athlon.rpm
        i386:
        ftp://updates.redhat.com/7.3/en/os/i386/kernel-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.3/en/os/i386/kernel-source-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.3/en/os/i386/kernel-doc-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.3/en/os/i386/kernel-BOOT-2.4.20-18.7.i386.rpm
        ftp://updates.redhat.com/7.3/en/os/i386/quota-3.06-9.7.i386.rpm
        i586:
        ftp://updates.redhat.com/7.3/en/os/i586/kernel-2.4.20-18.7.i586.rpm
        ftp://updates.redhat.com/7.3/en/os/i586/kernel-smp-2.4.20-18.7.i586.rpm
        i686:
        ftp://updates.redhat.com/7.3/en/os/i686/kernel-2.4.20-18.7.i686.rpm
        ftp://updates.redhat.com/7.3/en/os/i686/kernel-smp-2.4.20-18.7.i686.rpm
        ftp://updates.redhat.com/7.3/en/os/i686/kernel-bigmem-2.4.20-18.7.i686.rpm
        Red Hat Linux 8.0:
        SRPMS:
        ftp://updates.redhat.com/8.0/en/os/SRPMS/kernel-2.4.20-18.8.src.rpm
        athlon:
        ftp://updates.redhat.com/8.0/en/os/athlon/kernel-2.4.20-18.8.athlon.rpm
        

- 漏洞信息

12329
wmtv Multiple Unspecified Overflows
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-02-07 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

WMTV Buffer Overflow Vulnerability
Boundary Condition Error 4054
No Yes
2002-02-07 12:00:00 2009-07-11 10:56:00
This issue was publicized in a Debian Security Advisory on February 7th, 2002.

- 受影响的程序版本

wliang wmtv 0.6.5
- Debian Linux 2.2

- 漏洞讨论

wmtv is a video4linux TV player for windowmaker. It runs on Linux and Unix variants using windowmaker. It ships with Debian GNU/Linux 2.2.

A number of buffer overflows exist in affected versions of wmtv. This may provide an opportunity for a local attacker to execute arbitrary attacked-supplied instructions.

wmtv is installed setuid root by default, and affected versions require these privileges to run. Successful exploitation of this issue will allow the local attacker to gain root privileges on a host running vulnerable versions of wmtv.

However, it should be noted that it has not been proven whether these issues are exploitable.

This appears to be a problem with the version of wmtp that ships with Debian/GNU Linux due to the permissions that are required to run vulnerable versions of the software.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Upgrades are available.


wliang wmtv 0.6.5

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站