CVE-2002-0223
CVSS7.5
发布时间 :2002-05-16 00:00:00
修订时间 :2008-09-10 20:00:44
NMCOS    

[原文]Infopop UBB.Threads 5.4 and Wired Community Software WWWThreads 5.0 through 5.0.9 allows remote attackers to upload arbitrary files by using a filename that contains an accepted extension, but ends in a different extension.


[CNNVD]UBBThreads/WWWThreads任意文件上传漏洞(CNNVD-200205-041)

        Infopop UBB.Threads 5.4版本和Wired Community Software WWWThreads 5.0到5.0.9版本存在漏洞。远程攻击者通过使用可接受的扩展名但以另一扩展名结尾文件名上传任意文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:wired_community_software:wwwthreads:5.0.8
cpe:/a:infopop:ultimate_bulletin_board:5.4
cpe:/a:wired_community_software:wwwthreads:5.0
cpe:/a:wired_community_software:wwwthreads:5.0.9
cpe:/a:wired_community_software:wwwthreads:5.0.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0223
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0223
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200205-041
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/8022.php
(VENDOR_ADVISORY)  XF  ubbthreads-file-upload(8022)
http://online.securityfocus.com/archive/1/253172
(VENDOR_ADVISORY)  BUGTRAQ  20020130 [ WWWThreads, UBBThreads ] Security Hole in upload system
http://www.securityfocus.com/bid/3993
(UNKNOWN)  BID  3993

- 漏洞信息

UBBThreads/WWWThreads任意文件上传漏洞
高危 输入验证
2002-05-16 00:00:00 2005-10-20 00:00:00
远程  
        Infopop UBB.Threads 5.4版本和Wired Community Software WWWThreads 5.0到5.0.9版本存在漏洞。远程攻击者通过使用可接受的扩展名但以另一扩展名结尾文件名上传任意文件。

- 公告与补丁

        This issue has been addressed in UBBThreads versions 5.5 and later.
        Information about upgrading can be found here:
        http://www.infopop.com/support/ubbthreads/index.html

- 漏洞信息

13046
UBB.threads / WWWThreads Malformed Extension Arbitrary File Upload

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-01-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

UBBThreads/WWWThreads Arbitrary File Upload Vulnerability
Input Validation Error 3993
Yes No
2002-01-30 12:00:00 2009-07-11 09:56:00
This issue was submitted to BugTraq by Root Extractor <condor@phreaker.net> on January 30th, 2002.

- 受影响的程序版本

Wired Community Software WWWThreads 5.0 .9
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Microsoft IIS 5.0
- Microsoft IIS 4.0
Wired Community Software WWWThreads 5.0 .8
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Microsoft IIS 5.0
- Microsoft IIS 4.0
Wired Community Software WWWThreads 5.0 .6
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Microsoft IIS 5.0
- Microsoft IIS 4.0
Wired Community Software WWWThreads 5.0
Infopop UBBThreads 5.4
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Microsoft IIS 5.0
- Microsoft IIS 4.0
Infopop UBBThreads 5.5
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Microsoft IIS 5.0
- Microsoft IIS 4.0

- 不受影响的程序版本

Infopop UBBThreads 5.5
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Microsoft IIS 5.0
- Microsoft IIS 4.0

- 漏洞讨论

UBBThreads is a customizable, commercial database-driven message board. Seperate versions are available in both PHP and Perl. UBBThreads used to be called WWWThreads before being acquired and repackaged by Infopop from its previous maintainer Wired Community Software. Sites running UBBThreads and WWWThreads should be considered prone to this issue. UBBThreads/WWWThreads will run on most Unix and Linux variants, in addition to Microsoft Windows NT/2000 operating systems.

UBBThreads/WWWThreads allows users to upload certain types of files to the message board. For example, users may upload .txt, .jpg, .bmp, or .zip files.

However, a vulnerability has been discovered which may allow a remote attacker to upload arbitrary files. If the attacker adds a second file extension, only the first file extension will be checked by the message board. For example, a file entitled "file.txt.php" will pass through the filter, as the message board will assume it is of a permitted file type based on the first file extension.

In the case of a malicious PHP script, it may be possible for the attacker to execute it via the message board interface.

This issue reportedly affects the PHP version of the software.

- 漏洞利用

There is no exploit required.

- 解决方案

This issue has been addressed in UBBThreads versions 5.5 and later.

Information about upgrading can be found here:

http://www.infopop.com/support/ubbthreads/index.html

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站