CVE-2002-0220
CVSS7.5
发布时间 :2002-05-16 00:00:00
修订时间 :2008-09-10 20:00:44
NMCOS    

[原文]phpsmssend.php in PhpSmsSend 1.0 allows remote attackers to execute arbitrary commands via an SMS message containing shell metacharacters.


[CNNVD]PhpSmsSend远程执行任意命令漏洞(CNNVD-200205-018)

        
        PhpSmsSend是一个SmsSend的PHP界面程序,可以使用户通过Web界面发送SMS短消息,此程序可以在Linux和Windows平台下使用。
        PhpSmsSend存在输入验证漏洞,可以使远程攻击者在主机上执行任意命令。
        程序未对用户输入做充分过滤,远程攻击者可以在输入中插入特定的shell转义字符,从而在主机上以httpd进程的身份执行任意shell命令。有问题的代码:
        $str = SMSSEND." ".SCRIPTSPATH.$script." $params -- -d 0 ".PROXY;
        system($str,$res);
        如果在用户输入的短消息中插入反引号"`",反引号里的命令就会被执行。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0220
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0220
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200205-018
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/8019.php
(VENDOR_ADVISORY)  XF  phpsmssend-command-execution(8019)
http://www.securityfocus.com/bid/3982
(UNKNOWN)  BID  3982

- 漏洞信息

PhpSmsSend远程执行任意命令漏洞
高危 输入验证
2002-05-16 00:00:00 2005-10-20 00:00:00
远程  
        
        PhpSmsSend是一个SmsSend的PHP界面程序,可以使用户通过Web界面发送SMS短消息,此程序可以在Linux和Windows平台下使用。
        PhpSmsSend存在输入验证漏洞,可以使远程攻击者在主机上执行任意命令。
        程序未对用户输入做充分过滤,远程攻击者可以在输入中插入特定的shell转义字符,从而在主机上以httpd进程的身份执行任意shell命令。有问题的代码:
        $str = SMSSEND." ".SCRIPTSPATH.$script." $params -- -d 0 ".PROXY;
        system($str,$res);
        如果在用户输入的短消息中插入反引号"`",反引号里的命令就会被执行。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时停止此程序的使用。
        厂商补丁:
        PhpSmsSend
        ----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://zekiller.skytech.org/smssend.php

- 漏洞信息

14329
PhpSmsSend phpsmssend.php SMS Message Shell Metacharacter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

- 时间线

2002-01-29 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PhpSmsSend Remote Shell Command Execution Vulnerability
Input Validation Error 3982
Yes No
2002-01-29 12:00:00 2009-07-11 09:56:00
Posted to the Bugtraq mailing list by Indra Kusuma <indra@kusuma.or.id>.

- 受影响的程序版本

PhpSmsSend PhpSmsSend 1.0

- 漏洞讨论

PhpSmsSend is a front end to the SmsSend program, and allows users to send SMS messages through a web interface. SmsSend is available for Linux and Microsoft Windows.

PhpSmsSend does not properly validate user supplied input which is passed to a shell command. It is possible to execute arbitrary shell commands as the web server, generally user 'nobody'. This may lead to local access to the vulnerable system.

- 漏洞利用

This vulnerability can be exploited with a web browser.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站