CVE-2002-0204
CVSS7.5
发布时间 :2002-05-16 00:00:00
修订时间 :2016-10-17 22:17:05
NMCOS    

[原文]Buffer overflow in GNU Chess (gnuchess) 5.02 and earlier, if modified or used in a networked capacity contrary to its own design as a single-user application, may allow local or remote attackers to execute arbitrary code via a long command.


[CNNVD]GNU Chess命令缓冲区溢出漏洞(CNNVD-200205-043)

        GNU Chess (gnuchess) 5.02及其早期版本存在缓冲区溢出漏洞。如果在与他作为单用户应用程序时设计相反的网络性能中修改或使用时,本地或者远程攻击者借助超长命令执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0204
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0204
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200205-043
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=101189688815514&w=2
(UNKNOWN)  BUGTRAQ  20020124 gnuchess buffer overflow vulnerabilty
http://www.iss.net/security_center/static/7991.php
(VENDOR_ADVISORY)  XF  gnu-chess-bo(7991)
http://www.securityfocus.com/bid/3949
(UNKNOWN)  BID  3949

- 漏洞信息

GNU Chess命令缓冲区溢出漏洞
高危 缓冲区溢出
2002-05-16 00:00:00 2005-10-20 00:00:00
?????  
        GNU Chess (gnuchess) 5.02及其早期版本存在缓冲区溢出漏洞。如果在与他作为单用户应用程序时设计相反的网络性能中修改或使用时,本地或者远程攻击者借助超长命令执行任意代码。

- 公告与补丁

        The vendor has addressed this issue in v5.03beta of the software.
        GNU Chess 5.0 2
        

- 漏洞信息

59553
GNU Chess (gnuchess) Command Handling Overflow
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2002-01-24 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNU Chess Command Buffer Overflow Vulnerability
Boundary Condition Error 3949
No No
2002-01-22 12:00:00 2009-07-11 09:56:00
This vulnerability was submitted to BugTraq by Bernhard Kuemel <darsie@gmx.at> on January 22nd, 2002.

- 受影响的程序版本

GNU Chess 5.0 2
- Debian Linux 2.2 r3 unstable
GNU Chess 5.0 3beta

- 不受影响的程序版本

GNU Chess 5.0 3beta

- 漏洞讨论

GNU Chess is a freely available, open-source Chess engine that will run on most Unix and Linux variants.

GNU Chess does not perform sufficient bounds checking on commands. This is theoretically a security concern depending on the type of interface that is being used with the engine, if any. In situations where data can be supplied from an external source, this may become an exploitable security issue.

If the buffer can be overrun by an attacker via a maliciously constructed command which is passed through an interface, then it is possible to overwrite stack variables (including the return address) with attacker-supplied instructions.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has addressed this issue in v5.03beta of the software.


GNU Chess 5.0 2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站