发布时间 :2002-05-16 00:00:00
修订时间 :2008-09-05 16:27:23

[原文]mod_python version 2.7.6 and earlier allows a module indirectly imported by a published module to then be accessed via the publisher, which allows remote attackers to call possibly dangerous functions from the imported module.

[CNNVD]Gregory Trubetskoy mod_python输入模块访问漏洞(CNNVD-200205-010)

        mod_python 2.7.6及其早期版本允许模块通过已发布模块间接地输入然后借助发布者访问。远程攻击者从输入模块调用可能危险的函数。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  4656
(UNKNOWN)  XF  modpython-imported-module-access(8997)

- 漏洞信息

Gregory Trubetskoy mod_python输入模块访问漏洞
高危 访问验证错误
2002-05-16 00:00:00 2005-09-14 00:00:00
        mod_python 2.7.6及其早期版本允许模块通过已发布模块间接地输入然后借助发布者访问。远程攻击者从输入模块调用可能危险的函数。

- 公告与补丁

        Javier Quinteros has suggested that including the following line at the top of sensitive modules will prevent direct access:
        __auth__ = {}
        An updated version is available:
        Gregory Trubetskoy mod_python 2.7
        Gregory Trubetskoy mod_python 2.7.1
        Gregory Trubetskoy mod_python 2.7.2
        Gregory Trubetskoy mod_python 2.7.3
        Gregory Trubetskoy mod_python 2.7.4
        Gregory Trubetskoy mod_python 2.7.5
        Gregory Trubetskoy mod_python 2.7.6
        Gregory Trubetskoy mod_python 2.7.7

- 漏洞信息

Apache mod_python Module Importing Privilege Function Execution
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

Mod_Python contains a flaw that may allow a malicious user to bypass safeguards intended to prevent users from writing python scripts that contain dangerous functions. It is possible that the flaw may allow code execution, resulting in a loss of confidentiality and/or integrity.

- 时间线

2002-05-02 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.7.8 or higher, as it has been reported to fix this vulnerability. In addition, the vendor has released a patch for some older versions.

- 相关参考

- 漏洞作者