CVE-2002-0166
CVSS7.5
发布时间 :2002-04-22 00:00:00
修订时间 :2008-09-10 20:00:37
NMCO    

[原文]Cross-site scripting vulnerability in analog before 5.22 allows remote attackers to execute Javascript via an HTTP request containing the script, which is entered into a web logfile and not properly filtered by analog during display.


[CNNVD]Analog logfile脚本代码插入漏洞(CNNVD-200204-027)

        
        Analog是一款日志分析程序,支持在HTML中限制可打印格式化日志文件,运行在Unix和Linux系统下,也可以运行在Microsoft Windows系统下。
        Analog在日志处理上缺少正确检查,可导致跨站脚本执行漏洞。
        攻击者可以方便的插入任意字符串到任何WEB服务器日志文件中,如果这些日志文件中的字符串被analog解析,就会出现在HTML形式报告中,当这些字符串包含恶意功能的时候,其代码将会在第三方查看这些日志的时候在用户浏览器上执行,造成如基于Cookie认证的敏感信息泄露。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:stephen_turner:analog:4.03
cpe:/a:stephen_turner:analog:4.16
cpe:/a:stephen_turner:analog:4.91_beta1
cpe:/a:stephen_turner:analog:4.1
cpe:/a:stephen_turner:analog:3.90_beta1
cpe:/a:stephen_turner:analog:4.01
cpe:/a:stephen_turner:analog:4.04
cpe:/a:stephen_turner:analog:4.90_beta3
cpe:/a:stephen_turner:analog:4.11
cpe:/a:stephen_turner:analog:4.14
cpe:/a:stephen_turner:analog:4.90_beta4
cpe:/a:stephen_turner:analog:5.2
cpe:/a:stephen_turner:analog:5.02
cpe:/a:stephen_turner:analog:3.90_beta2
cpe:/a:stephen_turner:analog:4.02
cpe:/a:stephen_turner:analog:4.15
cpe:/a:stephen_turner:analog:5.01
cpe:/a:stephen_turner:analog:5.0
cpe:/a:stephen_turner:analog:4.90_beta2
cpe:/a:stephen_turner:analog:5.03
cpe:/a:stephen_turner:analog:5.1a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0166
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0166
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200204-027
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2002/dsa-125
(VENDOR_ADVISORY)  DEBIAN  DSA-125
http://www.securityfocus.com/bid/4389
(UNKNOWN)  BID  4389
http://www.redhat.com/support/errata/RHSA-2002-059.html
(UNKNOWN)  REDHAT  RHSA-2002:059
http://www.osvdb.org/2059
(UNKNOWN)  OSVDB  2059
http://www.iss.net/security_center/static/8656.php
(UNKNOWN)  XF  analog-logfile-css(8656)
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SN-02:02.asc
(UNKNOWN)  FREEBSD  FreeBSD-SN-02:02

- 漏洞信息

Analog logfile脚本代码插入漏洞
高危 输入验证
2002-04-22 00:00:00 2005-05-02 00:00:00
远程  
        
        Analog是一款日志分析程序,支持在HTML中限制可打印格式化日志文件,运行在Unix和Linux系统下,也可以运行在Microsoft Windows系统下。
        Analog在日志处理上缺少正确检查,可导致跨站脚本执行漏洞。
        攻击者可以方便的插入任意字符串到任何WEB服务器日志文件中,如果这些日志文件中的字符串被analog解析,就会出现在HTML形式报告中,当这些字符串包含恶意功能的时候,其代码将会在第三方查看这些日志的时候在用户浏览器上执行,造成如基于Cookie认证的敏感信息泄露。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的解决方法。
        厂商补丁:
        Debian
        ------
        Debian已经为此发布了一个安全公告(DSA-125-1)以及相应补丁:
        DSA-125-1:New analog packages fix cross-site scripting vulnerability
        链接:
        http://www.debian.org/security/2002/dsa-125

        补丁下载:
        Source archives:
        
        http://security.debian.org/dists/stable/updates/main/source/analog_5.22-0potato1.dsc

        
        http://security.debian.org/dists/stable/updates/main/source/analog_5.22-0potato1.diff.gz

        
        http://security.debian.org/dists/stable/updates/main/source/analog_5.22.orig.tar.gz

        Alpha architecture:
        
        http://security.debian.org/dists/stable/updates/main/binary-alpha/analog_5.22-0potato1_alpha.deb

        ARM architecture:
        
        http://security.debian.org/dists/stable/updates/main/binary-arm/analog_5.22-0potato1_arm.deb

        Intel ia32 architecture:
        
        http://security.debian.org/dists/stable/updates/main/binary-i386/analog_5.22-0potato1_i386.deb

        Motorola 680x0 architecture:
        
        http://security.debian.org/dists/stable/updates/main/binary-m68k/analog_5.22-0potato1_m68k.deb

        PowerPC architecture:
        
        http://security.debian.org/dists/stable/updates/main/binary-powerpc/analog_5.22-0potato1_powerpc.deb

        Sun Sparc architecture:
        
        http://security.debian.org/dists/stable/updates/main/binary-sparc/analog_5.22-0potato1_sparc.deb

        Analog
        ------
        Analog 5.22已经修复这个安全问题,请到厂商的主页下载:
        Analog Upgrade Analog 5.22
        
        http://www.analog.cx/download.html

- 漏洞信息

2059
Analog Logfile Analysis XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Analog contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate log entries during analyzing. This could allow an attacker to create a specially crafted URL that would execute arbitrary code on the machine analyzing the logs.

- 时间线

2002-03-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.22 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站