CVE-2002-0121
CVSS2.1
发布时间 :2002-03-25 00:00:00
修订时间 :2008-09-10 20:00:32
NMCO    

[原文]PHP 4.0 through 4.1.1 stores session IDs in temporary files whose name contains the session ID, which allows local users to hijack web connections.


[CNNVD]PHP4 Session文件本地信息泄漏漏洞(CNNVD-200203-075)

        
        PHP是服务器端脚本语言,设计成内嵌于HTML文件的形式,可以运行于Windows, Linux和许多Unix操作系统。PHP在Web开发上使用非常广泛。
        PHP session信息默认存放在/tmp目录下,这些文件的名字包含了session ID。例如,对于/tmp/sess_g35g5g54gg45wg85文件,"g35g5g54gg45wg85"就是其Session ID。一个本地攻击者可以浏览/tmp目录的内容来获取这些session ID,并可能劫持当前Web会话,获取未授权信息。
        

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:4.1.0PHP PHP 4.1.0
cpe:/a:php:php:4.0.5PHP PHP 4.0.5
cpe:/a:php:php:4.0.6PHP PHP 4.0.6
cpe:/a:php:php:4.1.2PHP PHP 4.1.2
cpe:/a:php:php:4.0.4PHP PHP 4.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0121
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0121
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-075
(官方数据源) CNNVD

- 其它链接及资源

http://online.securityfocus.com/archive/1/250196
(PATCH)  BUGTRAQ  20020113 PHP 4.x session spoofing
http://www.iss.net/security_center/static/7908.php
(VENDOR_ADVISORY)  XF  php-session-temp-disclosure(7908)
http://www.securityfocus.com/bid/3873
(UNKNOWN)  BID  3873

- 漏洞信息

PHP4 Session文件本地信息泄漏漏洞
低危 设计错误
2002-03-25 00:00:00 2005-05-02 00:00:00
本地  
        
        PHP是服务器端脚本语言,设计成内嵌于HTML文件的形式,可以运行于Windows, Linux和许多Unix操作系统。PHP在Web开发上使用非常广泛。
        PHP session信息默认存放在/tmp目录下,这些文件的名字包含了session ID。例如,对于/tmp/sess_g35g5g54gg45wg85文件,"g35g5g54gg45wg85"就是其Session ID。一个本地攻击者可以浏览/tmp目录的内容来获取这些session ID,并可能劫持当前Web会话,获取未授权信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 修改php配置文件中session存放目录,使之独立出来,并修改新的session存放目录的属主为Web服务启动的属主,(例如一般apache的属主是nobody)再把该目录的属性改为300。
        厂商补丁:
        PHP
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.php.net

- 漏洞信息

2026
PHP4 Session Files Local Information Disclosure
Information Disclosure
Loss of Confidentiality

- 漏洞描述

PHP 4.0 through 4.1.1 stores session IDs in temporary files whose name contains the session ID, which allows local users to hijack web connections.

- 时间线

2002-01-13 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站