CVE-2002-0096
CVSS7.2
发布时间 :2002-03-25 00:00:00
修订时间 :2008-09-05 16:27:10
NMCO    

[原文]The installation of Geeklog 1.3 creates an extra group_assignments record which is not properly deleted, which causes the first newly created user to be added to the GroupAdmin and UserAdmin groups, which could provide that user with administrative privileges that were not intended.


[CNNVD]Geeklog新用户默认管理权限漏洞(CNNVD-200203-052)

        
        Geeklog是一个开源门户系统,可作为一种讲故事的软件,新闻系统或在线社区。
        Geeklog 1.3版本中存在配置错误可以允许非特权,一般用户登陆到服务获得管理员权限。
        由Geeklog建立的第一新用户帐户其属于GroupAdmin/UserAdmin,可以导致第一个用户有管理员的权限,可以完全控制整个Geeklog系统。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0096
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0096
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-052
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3783
(VENDOR_ADVISORY)  BID  3783
http://www.securityfocus.com/archive/1/248367
(VENDOR_ADVISORY)  BUGTRAQ  20020103 Vulnerability in new user creation in Geeklog 1.3
http://www.iss.net/security_center/static/7780.php
(VENDOR_ADVISORY)  XF  geeklog-default-admin-privileges(7780)
http://geeklog.sourceforge.net/index.php?topic=Security
(UNKNOWN)  CONFIRM  http://geeklog.sourceforge.net/index.php?topic=Security

- 漏洞信息

Geeklog新用户默认管理权限漏洞
高危 未知
2002-03-25 00:00:00 2005-05-02 00:00:00
本地  
        
        Geeklog是一个开源门户系统,可作为一种讲故事的软件,新闻系统或在线社区。
        Geeklog 1.3版本中存在配置错误可以允许非特权,一般用户登陆到服务获得管理员权限。
        由Geeklog建立的第一新用户帐户其属于GroupAdmin/UserAdmin,可以导致第一个用户有管理员的权限,可以完全控制整个Geeklog系统。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 如果你已经安装好Geeklog1.3就需要编辑UID为13的用户,进入MYSQL,输入如下查询:"SELECT username FROM users WHERE uid = 13",然后在admin/users.php页面中编辑用户属性,去掉GroupAdmin Group 和 the UserAdmin Group的选项框选择。
        厂商补丁:
        Geeklog
        -------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://geeklog.sourceforge.net/

- 漏洞信息

2016
Geeklog New User Default Admin Privileges
Remote / Network Access Authentication Management
Loss of Integrity
Exploit Public

- 漏洞描述

Geeklog contains a flaw that may allow a remote attacker to gain access to unauthorized privileges. The issue is triggered during the installation, which creates an extra 'group_assignments' record with a user id of 13, but the user table only contains 12 users. The first new created user is a member of the GroupAdmin Group and the UserAdmin Group which could allow a remote attacker to gain access to administrative privileges resulting in a loss of integrity.

- 时间线

2002-01-03 Unknow
2002-01-03 Unknow

- 解决方案

Upgrade to version 1.3.1 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: In your MySQL editor enter the following command: SELECT username FROM users WHERE uid = 13 Afterwards, edit this user in admin/users.php and uncheck the 'GroupAdmin Group' and the 'UserAdmin Group' check boxes.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站