CVE-2002-0093
CVSS7.2
发布时间 :2002-09-05 00:00:00
修订时间 :2011-03-07 21:07:45
NMCOS    

[原文]Buffer overflow in ipcs for HP Tru64 UNIX 4.0f through 5.1a may allow attackers to execute arbitrary code, a different vulnerability than CVE-2001-0423.


[CNNVD]Tru64 IPCS本地缓冲区溢出漏洞(CNNVD-200209-019)

        
        Tru64是一款由HP公司开发的UNIX操作系统。
        Tru64中的ipcs程序在处理用户提交的参数时缺少正确的检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        Tru64中的/usr/bin/ipcs用于报告内部进程通信状态的程序,默认以suid root属性安装,本地攻击者可以利用漏洞破坏内存,可能以root用户权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:compaq:tru64:4.0gCompaq Tru64 4.0g
cpe:/o:compaq:tru64:5.1Compaq Tru64 5.1
cpe:/o:compaq:tru64:5.1aCompaq Tru64 5.1a
cpe:/o:compaq:tru64:4.0fCompaq Tru64 4.0f
cpe:/o:compaq:tru64:5.0aCompaq Tru64 5.0a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0093
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0093
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200209-019
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/771155
(UNKNOWN)  CERT-VN  VU#771155
http://www.securityfocus.com/bid/5241
(VENDOR_ADVISORY)  BID  5241
http://www.iss.net/security_center/static/9613.php
(VENDOR_ADVISORY)  XF  tru64-ipcs-bo(9613)
http://archives.neohapsis.com/archives/compaq/2002-q3/0010.html
(UNKNOWN)  HP  SSRT2275
http://archives.neohapsis.com/archives/compaq/2002-q3/0010.html
(UNKNOWN)  HP  SSRT2275

- 漏洞信息

Tru64 IPCS本地缓冲区溢出漏洞
高危 边界条件错误
2002-09-05 00:00:00 2005-10-20 00:00:00
本地  
        
        Tru64是一款由HP公司开发的UNIX操作系统。
        Tru64中的ipcs程序在处理用户提交的参数时缺少正确的检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        Tru64中的/usr/bin/ipcs用于报告内部进程通信状态的程序,默认以suid root属性安装,本地攻击者可以利用漏洞破坏内存,可能以root用户权限在系统上执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        Compaq
        ------
        Compaq已经为此发布了一个安全公告(SSRT0794U)以及相应补丁:
        SSRT0794U:SSRT0794U HP Tru64 UNIX Potential Overflow in /usr/bin/ipcs
        链接:
        补丁下载:
        Compaq Tru64 4.0 g:
        HP Patch T64V40GB17-C0011702-14557-ES-20020611.tar
        
        http://ftp.support.compaq.com/patches/public/unix/v4.0g/

        Kit Applies To: Tru64 UNIX 4.0G PK3 (BL17)
        Compaq Tru64 4.0 f:
        HP Patch DUV40FB18-C0069705-14559-ES-20020611.tar
        
        http://ftp.support.compaq.com/patches/public/unix/v4.0f/

        Kit Applies To: Tru64 UNIX 4.0F PK7 (BL18)
        Compaq Tru64 5.0 a:
        HP Patch T64V50AB17-C0019402-14556-ES-20020611.tar
        
        http://ftp.support.compaq.com/patches/public/unix/v5.0a/

        Kit Applies To: Tru64 UNIX 5.0A PK3 (BL17)
        Compaq Tru64 5.1 a:
        HP Patch T64V51AB2-C0015807-14563-ES-20020611.tar
        
        http://ftp.support.compaq.com/patches/public/unix/v5.1a/

        Kit Applies To: Tru64 UNIX 5.1A PK2 (BL2)
        Compaq Tru64 5.1:
        HP Patch T64V51B19-C0109706-14562-ES-20020611.tar
        
        http://ftp.support.compaq.com/patches/public/unix/v5.1/

        Kit Applies To: Tru64 UNIX 5.1 PK5 (BL19)

- 漏洞信息

11365
HP Tru64 UNIX ipcs Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-07-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Tru64 IPCS Buffer Overflow Vulnerability
Boundary Condition Error 5241
No Yes
2002-07-16 12:00:00 2009-07-11 02:56:00
This issue was announced in a Tru64 Unix advisory.

- 受影响的程序版本

Compaq Tru64 5.1 a
Compaq Tru64 5.1
Compaq Tru64 5.0 a
Compaq Tru64 4.0 g
Compaq Tru64 4.0 f

- 漏洞讨论

The ipcs utility for Tru64 Unix is prone to a buffer overflow condition. Local attackers may exploit this condition to cause memory to be corrupted and potentially execute arbitrary code as root.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Fixes are available:


Compaq Tru64 4.0 g

Compaq Tru64 4.0 f

Compaq Tru64 5.0 a

Compaq Tru64 5.1

Compaq Tru64 5.1 a

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站