CVE-2002-0091
CVSS7.5
发布时间 :2002-03-15 00:00:00
修订时间 :2008-09-05 16:27:09
NMCOS    

[原文]Multiple CGI scripts in CIDER SHADOW 1.5 and 1.6 allows remote attackers to execute arbitrary commands via certain form fields.


[CNNVD]CIDER SHADOW远程可执行任意命令漏洞(CNNVD-200203-041)

        
        CIDER SHADOW是一款NSWC开发和维护的入侵检测程序,可以使用在多种Unix和Linux操作系统下。
        CIDER SHADOW中多个CGI脚本对用户提交的数据缺少充分正确的检查,可导致远程攻击者以httpd进程的权限在主机上执行任意命令。
        由于CIDER SHADOW脚本对攻击者提供给变量的数据缺少正确检查,远程攻击者可以构建特殊的URL并提交给CIDER SHADOW,导致其以httpd进程的权限在目标系统执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:nswc:cider_shadow:1.6
cpe:/a:nswc:cider_shadow:1.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0091
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0091
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-041
(官方数据源) CNNVD

- 其它链接及资源

http://www.esecurityonline.com/advisories/eSO2408.asp
(VENDOR_ADVISORY)  MISC  http://www.esecurityonline.com/advisories/eSO2408.asp
http://www.securityfocus.com/bid/4625
(UNKNOWN)  BID  4625
http://www.iss.net/security_center/static/8953.php
(UNKNOWN)  XF  shadow-cgi-execute-commands(8953)
http://archives.neohapsis.com/archives/bugtraq/2002-04/0400.html
(UNKNOWN)  BUGTRAQ  20020429 eSecurityOnline Security Advisory 2408 - CIDER SHADOW CGI

- 漏洞信息

CIDER SHADOW远程可执行任意命令漏洞
高危 输入验证
2002-03-15 00:00:00 2005-10-20 00:00:00
远程  
        
        CIDER SHADOW是一款NSWC开发和维护的入侵检测程序,可以使用在多种Unix和Linux操作系统下。
        CIDER SHADOW中多个CGI脚本对用户提交的数据缺少充分正确的检查,可导致远程攻击者以httpd进程的权限在主机上执行任意命令。
        由于CIDER SHADOW脚本对攻击者提供给变量的数据缺少正确检查,远程攻击者可以构建特殊的URL并提交给CIDER SHADOW,导致其以httpd进程的权限在目标系统执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 默认设计中,CIDER SHADOW 的WEB接口只允许通过内部网络和通过密码验证后进行访问,如果用户提供了外部网络访问,请关闭外部网络访问WEB接口功能并只能本地查看WEB页面。
        厂商补丁:
        CIDER
        -----
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.nswc.navy.mil/ISSEC/CID/

- 漏洞信息

10392
CIDER SHADOW Multiple Unspecified CGI Arbitrary Command Execution
Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-04-29 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CIDER Shadow Analyzer Remote Command Execution Vulnerability
Input Validation Error 4625
Yes No
2002-04-29 12:00:00 2009-07-11 12:46:00
Discovery of this issue is credited to Kevin Kotas of the eSecurityOnline Research and Development Team.

- 受影响的程序版本

CIDER Shadow 1.6
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
CIDER Shadow 1.5
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18

- 漏洞讨论

CIDER (Cooperative Intrusion Detection Evaluation and Response) Shadow Analyzer is a component of the Shadow Intrusion Detection System. It will run on a number of Linux distributions. The CIDER Shadow Analyzer component is intended to be only accessible within the internal network.

The CIDER Shadow Analyzer does not adequately filter shell metacharacters. As a result, remote attackers may execute commands on the underlying host with the privileges of the webserver process.

This may enable a remote attacker within the internal network to gain local access to the host running the vulnerable software.

It is not known whether CIDER Shadow 1.7 is also affected by this issue.

- 漏洞利用

This issue may be exploited with a web browser.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站