CVE-2002-0090
CVSS7.2
发布时间 :2002-03-15 00:00:00
修订时间 :2008-09-10 15:11:19
NMCOS    

[原文]Buffer overflow in Low BandWidth X proxy (lbxproxy) in Solaris 8 allows local users to execute arbitrary code via a long display command line option.


[CNNVD]Sun Solaris lbxproxy display参数本地缓冲区溢出漏洞(CNNVD-200203-037)

        
        lbxproxy是一款设计利用压缩和解压算法增加通过低带宽internet和串行连接的X性能的程序。
        lbxproxy在处理display命令行参数的时候存在问题,可导致本地攻击者进行缓冲溢出区攻击。
        攻击者可以提交超长字符串给display命令行参数并执行时,由于lbxproxy对其缓冲边界缺少充分正确的检查,可导致缓冲区溢出,精心构建超长字符串数据,可使本地攻击者获得主机的root权限。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:86Solaris 8 LBXProxy Display Name Buffer Overflow
oval:org.mitre.oval:def:179Solaris 7 LBXProxy Display Name Buffer Overflow
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0090
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0090
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-037
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/188507
(VENDOR_ADVISORY)  CERT-VN  VU#188507
http://www.esecurityonline.com/advisories/eSO3761.asp
(VENDOR_ADVISORY)  MISC  http://www.esecurityonline.com/advisories/eSO3761.asp
http://www.securityfocus.com/bid/4633
(UNKNOWN)  BID  4633
http://www.iss.net/security_center/static/8958.php
(UNKNOWN)  XF  solaris-lbxproxy-display-bo(8958)
http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsalert/44842
(UNKNOWN)  SUNALERT  44842
http://online.securityfocus.com/archive/1/270149
(UNKNOWN)  BUGTRAQ  20020429 eSecurityOnline Security Advisory 3761 - Sun Solaris lbxproxy display name buffer overflow vulnerability
http://archives.neohapsis.com/archives/vulnwatch/2002-q2/0041.html
(UNKNOWN)  VULNWATCH  20020429 [VulnWatch] eSecurityOnline Security Advisory 3761 - Sun Solaris lbxproxy display name buffer overflow vulnerability

- 漏洞信息

Sun Solaris lbxproxy display参数本地缓冲区溢出漏洞
高危 边界条件错误
2002-03-15 00:00:00 2005-05-13 00:00:00
本地  
        
        lbxproxy是一款设计利用压缩和解压算法增加通过低带宽internet和串行连接的X性能的程序。
        lbxproxy在处理display命令行参数的时候存在问题,可导致本地攻击者进行缓冲溢出区攻击。
        攻击者可以提交超长字符串给display命令行参数并执行时,由于lbxproxy对其缓冲边界缺少充分正确的检查,可导致缓冲区溢出,精心构建超长字符串数据,可使本地攻击者获得主机的root权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * chmod -s /usr/openwin/bin/lbxproxy
        厂商补丁:
        Sun
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://sunsolve.sun.com

- 漏洞信息

8711
Solaris lbxproxy Display Argument Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-04-29 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Solaris LBXProxy Display Name Buffer Overflow Vulnerability
Boundary Condition Error 4633
No Yes
2002-04-29 12:00:00 2009-07-11 12:46:00
Discovery of this issue is credited to Kevin Kotas of the eSecurityOnline Research and Development Team.

- 受影响的程序版本

Sun Solaris 9
Sun Solaris 8_x86
Sun Solaris 8_sparc
Sun Solaris 7.0_x86
Sun Solaris 7.0

- 漏洞讨论

Low-Bandwidth X Proxy (lbxproxy) is a server that handles low-bandwidth connections to X Windows. It runs on Solaris as well as a number of Unix and Linux variants.

lbxproxy is prone to a locally exploitable buffer overflow condition. This is due to insufficient bounds checking of the display name command line option.

Successful exploitation will enable an attacker to execute arbitrary attacker-supplied instructions and as a consequence gain elevated privileges.

This issue was reported for lbxproxy on the Sun Solaris operating system. It is not known whether this is an issue on other operating systems.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Patches are available:


Sun Solaris 7.0_x86

Sun Solaris 7.0

Sun Solaris 8_x86

Sun Solaris 8_sparc

Sun Solaris 9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站