CVE-2002-0062
CVSS7.2
发布时间 :2002-03-08 00:00:00
修订时间 :2008-09-05 16:27:04
NMCO    

[原文]Buffer overflow in ncurses 5.0, and the ncurses4 compatibility package as used in Red Hat Linux, allows local users to gain privileges, related to "routines for moving the physical cursor and scrolling."


[CNNVD]ncurses缓冲区溢出漏洞(CNNVD-200203-020)

        ncurses 5.0版本和使用于Red Hat Linux的ncurses4兼容性数据包存在缓冲区溢出漏洞。本地用户提升特权,该漏洞与“移动和卷动实体光标的惯例”有关。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:redhat:linux:7.1::alpha
cpe:/o:redhat:linux:6.1::i386
cpe:/o:suse:suse_linux:6.3SuSE SuSE Linux 6.3
cpe:/o:freebsd:freebsd:3.5.1FreeBSD 3.5.1
cpe:/o:freebsd:freebsd:5.0FreeBSD 5.0
cpe:/o:freebsd:freebsd:3.4FreeBSD 3.4
cpe:/o:freebsd:freebsd:3.2FreeBSD 3.2
cpe:/o:redhat:linux:7.0::alpha
cpe:/o:freebsd:freebsd:3.5FreeBSD 3.5
cpe:/o:freebsd:freebsd:3.1FreeBSD 3.1
cpe:/o:debian:debian_linux:2.2::powerpc
cpe:/o:redhat:linux:6.1::alpha
cpe:/o:debian:debian_linux:2.2::68k
cpe:/o:redhat:linux:7.0::i386
cpe:/o:debian:debian_linux:2.2::alpha
cpe:/o:redhat:linux:7.1::i386
cpe:/o:freebsd:freebsd:4.1FreeBSD 4.1
cpe:/o:suse:suse_linux:6.2SuSE SuSE Linux 6.2
cpe:/o:debian:debian_linux:2.2::arm
cpe:/o:redhat:linux:6.1::sparc
cpe:/o:freebsd:freebsd:4.1.1FreeBSD 4.1.1
cpe:/o:redhat:linux:7.2::i386
cpe:/o:suse:suse_linux:7.0SuSE SuSE Linux 7.0
cpe:/o:debian:debian_linux:2.2::ia-32
cpe:/o:debian:debian_linux:2.2::sparc
cpe:/o:freebsd:freebsd:3.3FreeBSD 3.3
cpe:/o:freebsd:freebsd:4.0FreeBSD 4.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0062
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0062
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-020
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2116
(VENDOR_ADVISORY)  BID  2116
http://www.redhat.com/support/errata/RHSA-2002-020.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2002:020
http://www.debian.org/security/2002/dsa-113
(VENDOR_ADVISORY)  DEBIAN  DSA-113
http://www.iss.net/security_center/static/8222.php
(UNKNOWN)  XF  gnu-ncurses-window-bo(8222)

- 漏洞信息

ncurses缓冲区溢出漏洞
高危 缓冲区溢出
2002-03-08 00:00:00 2005-10-12 00:00:00
本地  
        ncurses 5.0版本和使用于Red Hat Linux的ncurses4兼容性数据包存在缓冲区溢出漏洞。本地用户提升特权,该漏洞与“移动和卷动实体光标的惯例”有关。

- 公告与补丁

        

- 漏洞信息

5389
ncurses Cursor/Scrolling Routine Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站