发布时间 :2002-01-31 00:00:00
修订时间 :2008-09-10 15:11:03

[原文]Bugzilla before 2.14.1 allows remote attackers to inject arbitrary SQL code and create files or gain privileges via (1) the sql parameter in buglist.cgi, (2) invalid field names from the "boolean chart" query in buglist.cgi, (3) the mybugslink parameter in userprefs.cgi, (4) a malformed bug ID in the buglist parameter in long_list.cgi, and (5) the value parameter in editusers.cgi, which allows groupset privileges to be modified by attackers with blessgroupset privileges.

[CNNVD]BugZilla BugList.CGI SQL查询操控漏洞(CNNVD-200201-012)

        Bugzilla 2.14.1之前版本存在漏洞。远程攻击者借助(1)buglist.cgi中的sql参数,(2)buglist.cgi中"boolean chart"查询的无效字段名,(3)userprefs.cgi中的mybugslink参数,(4)long_list.cgi中buglist参数的畸形漏洞ID,以及(5)editusers.cgi中的value参数注入任意SQL代码以及创建文件或者提升特权,具有blessgroupset特权的攻击者可以修改groupset特权。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  BUGTRAQ  20020105 Security Advisory for Bugzilla v2.15 (cvs20020103) and older
(UNKNOWN)  BID  3805
(UNKNOWN)  BID  3804
(UNKNOWN)  BID  3802
(UNKNOWN)  BID  3801
(UNKNOWN)  XF  bugzilla-editusers-change-groupset(7814)
(UNKNOWN)  XF  bugzilla-buglist-sql-logic(7813)
(UNKNOWN)  XF  bugzilla-longlist-modify-sql(7811)
(UNKNOWN)  XF  bugzilla-userprefs-change-groupset(7809)
(UNKNOWN)  XF  bugzilla-buglist-modify-sql(7807)
(UNKNOWN)  BUGTRAQ  20020106 Inproper input validation in Bugzilla <=2.14 - exploit

- 漏洞信息

BugZilla BugList.CGI SQL查询操控漏洞
高危 输入验证
2002-01-31 00:00:00 2005-10-20 00:00:00
        Bugzilla 2.14.1之前版本存在漏洞。远程攻击者借助(1)buglist.cgi中的sql参数,(2)buglist.cgi中"boolean chart"查询的无效字段名,(3)userprefs.cgi中的mybugslink参数,(4)long_list.cgi中buglist参数的畸形漏洞ID,以及(5)editusers.cgi中的value参数注入任意SQL代码以及创建文件或者提升特权,具有blessgroupset特权的攻击者可以修改groupset特权。

- 公告与补丁

        This issue has been addressed by the vendor is versions 2.14.1 and later. Users are advised to upgrade to the most recent version.
        It should also be noted that users who are running version 2.15 checked out of
        cvs prior to 15 December 2001 are strongly recommended to use 'cvs update' to obtain the current cvs code.
        Mozilla Bugzilla 2.10
        Mozilla Bugzilla 2.12
        Mozilla Bugzilla 2.14
        Mozilla Bugzilla 2.4
        Mozilla Bugzilla 2.6
        Mozilla Bugzilla 2.8

- 漏洞信息

Bugzilla buglist.cgi WHERE Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Bugzilla contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'buglist.cgi' script not properly sanitizing user-supplied input to the 'WHERE' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

- 时间线

2002-01-05 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.14.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete