CVE-2002-0003
CVSS7.5
发布时间 :2002-02-27 00:00:00
修订时间 :2008-09-05 16:26:56
NMCO    

[原文]Buffer overflow in the preprocessor in groff 1.16 and earlier allows remote attackers to gain privileges via lpd in the LPRng printing system.


[CNNVD]Groff预处理器缓冲区溢出漏洞(CNNVD-200202-011)

        
        groff是在许多Linux系统上使用的文档格式化工具。groff通常在需要格式化文档的时候由LPRng(或其他的打印程序)调用。
        groff的预处理程序存在缓冲区溢出漏洞,可能使远程攻击者以lp用户的身份执行任意指令。
        如果攻击者可以从远程访问主机的打印守护进程,并且知道打印机名和队列文件名,就可能从远程以lp用户的身份在主机上执行命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0003
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0003
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200202-011
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2002-004.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2002:004
http://xforce.iss.net/xforce/xfdb/7881
(UNKNOWN)  XF  linux-groff-preprocessor-bo(7881)
http://www.securityfocus.com/bid/3869
(UNKNOWN)  BID  3869
http://www.linux-mandrake.com/en/security/2002/MDKSA-2002-012.php
(UNKNOWN)  MANDRAKE  MDKSA-2002:012
http://online.securityfocus.com/advisories/3793
(UNKNOWN)  HP  HPSBTL0201-014

- 漏洞信息

Groff预处理器缓冲区溢出漏洞
高危 边界条件错误
2002-02-27 00:00:00 2005-05-02 00:00:00
远程  
        
        groff是在许多Linux系统上使用的文档格式化工具。groff通常在需要格式化文档的时候由LPRng(或其他的打印程序)调用。
        groff的预处理程序存在缓冲区溢出漏洞,可能使远程攻击者以lp用户的身份执行任意指令。
        如果攻击者可以从远程访问主机的打印守护进程,并且知道打印机名和队列文件名,就可能从远程以lp用户的身份在主机上执行命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 设置访问控制,不允许不可信的用户访问打印守护进程。
        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2002:004-06)以及相应补丁:
        RHSA-2002:004-06:New groff packages available to fix security
        链接:https://www.redhat.com/support/errata/RHSA-2002-004.html
        补丁下载:
        Red Hat Linux 7.0:
        SRPMS:
        ftp://updates.redhat.com/7.0/en/os/SRPMS/groff-1.16-7.1.src.rpm
        alpha:
        ftp://updates.redhat.com/7.0/en/os/alpha/groff-1.16-7.1.alpha.rpm
        i386:
        ftp://updates.redhat.com/7.0/en/os/i386/groff-1.16-7.1.i386.rpm
        Red Hat Linux 7.1:
        SRPMS:
        ftp://updates.redhat.com/7.1/en/os/SRPMS/groff-1.17.2-7.0.2.src.rpm
        alpha:
        ftp://updates.redhat.com/7.1/en/os/alpha/groff-1.17.2-7.0.2.alpha.rpm
        i386:
        ftp://updates.redhat.com/7.1/en/os/i386/groff-1.17.2-7.0.2.i386.rpm
        ia64:
        ftp://updates.redhat.com/7.1/en/os/ia64/groff-1.17.2-7.0.2.ia64.rpm
        Red Hat Linux 7.2:
        SRPMS:
        ftp://updates.redhat.com/7.2/en/os/SRPMS/groff-1.17.2-7.0.2.src.rpm
        i386:
        ftp://updates.redhat.com/7.2/en/os/i386/groff-1.17.2-7.0.2.i386.rpm
        ia64:
        ftp://updates.redhat.com/7.2/en/os/ia64/groff-1.17.2-7.0.2.ia64.rpm
        可使用下列命令安装补丁:
        rpm -Fvh [文件名]

- 漏洞信息

2024
GNU groff Pre-Processor LPRng Printing System Overflow
Input Manipulation
Loss of Integrity Patch / RCS, Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-01-07 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站