CVE-2001-1580
CVSS5.0
发布时间 :2001-12-31 00:00:00
修订时间 :2008-09-05 16:26:54
NMCO    

[原文]Directory traversal vulnerability in ScriptEase viewcode.jse for Netware 5.1 before 5.1 SP3 allows remote attackers to read arbitrary files via ".." sequences in the query string.


[CNNVD]Nombas ScriptEase:Webserver Edition 缺省脚本存在安全漏洞(CNNVD-200112-199)

        
        Nombas ScriptEase:Webserver Edition 提供了基于Web的JavaScript开发环境,可以执行JavaScript来响应CGI请求,还提供了远程调试功能。
        该程序存在一个安全问题,可能导致任意文件泄露。
        其中的示例脚本"viewcode.jse"用来浏览脚本源代码,但是由于没有过滤"../",导致恶意攻击者可以利用该漏洞查看任意文件内容。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:nombas:scriptease_webserver:4.30b
cpe:/a:nombas:scriptease_webserver:4.30d
cpe:/o:novell:netware:5.1:sp2a
cpe:/o:novell:netware:5.1Novell NetWare 5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1580
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1580
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-199
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3715
(PATCH)  BID  3715
http://xforce.iss.net/static/7726.php
(UNKNOWN)  XF  netware-webserver-directory-traversal(7726)
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2001-12/0221.html
(UNKNOWN)  BUGTRAQ  20011220 Re: IRM Security Advisory 002: Netware Web Server Source Disclosure
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2001-12/0218.html
(UNKNOWN)  BUGTRAQ  20011220 Re: IRM Security Advisory 002: Netware Web Server Source Disclosure
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2001-12/0204.html
(VENDOR_ADVISORY)  BUGTRAQ  20011219 IRM Security Advisory 002: Netware Web Server Source Disclosure

- 漏洞信息

Nombas ScriptEase:Webserver Edition 缺省脚本存在安全漏洞
中危 输入验证
2001-12-31 00:00:00 2006-05-01 00:00:00
远程  
        
        Nombas ScriptEase:Webserver Edition 提供了基于Web的JavaScript开发环境,可以执行JavaScript来响应CGI请求,还提供了远程调试功能。
        该程序存在一个安全问题,可能导致任意文件泄露。
        其中的示例脚本"viewcode.jse"用来浏览脚本源代码,但是由于没有过滤"../",导致恶意攻击者可以利用该漏洞查看任意文件内容。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 删除所有示例脚本
        厂商补丁:
        Nombas ScriptEase
        -----------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.nombas.com/us/sewse/index.htm

- 漏洞信息

19252
Nombas ScriptEase Webserver Edition viewcode.jse Traversal Arbitrary File Access
Remote / Network Access Input Manipulation

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-12-19 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站