CVE-2001-1524
CVSS4.3
发布时间 :2001-12-31 00:00:00
修订时间 :2008-09-10 15:10:53
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in PHP-Nuke 5.3.1 and earlier allows remote attackers to inject arbitrary web script or HTML via the (1) uname parameter in user.php, (2) ttitle, letter and file parameters in modules.php, (3) subject, story and storyext parameters in submit.php, (4) upload parameter in admin.php and (5) fname parameter in friend.php.


[CNNVD]PHPNuke多个跨站脚本漏洞(CNNVD-200112-201)

        PHP-Nuke 5.3.1版本及之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)user.php的uname参数,(2)modules.php的ttitle、letter和file参数,(3)submit.php的subject、story和storyext参数,(4)admin.php的upload参数以及(5)friend.php的fname参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:francisco_burzi:php-nuke:5.0.1
cpe:/a:francisco_burzi:php-nuke:5.1
cpe:/a:francisco_burzi:php-nuke:5.0
cpe:/a:francisco_burzi:php-nuke:4.3
cpe:/a:francisco_burzi:php-nuke:3.0
cpe:/a:francisco_burzi:php-nuke:5.2a
cpe:/a:francisco_burzi:php-nuke:5.2
cpe:/a:francisco_burzi:php-nuke:4.4.1a
cpe:/a:francisco_burzi:php-nuke:4.0
cpe:/a:francisco_burzi:php-nuke:4.4
cpe:/a:francisco_burzi:php-nuke:5.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1524
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1524
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-201
(官方数据源) CNNVD

- 其它链接及资源

http://prdownloads.sourceforge.net/phpnuke/PHP-Nuke-5.5.tar.gz
(PATCH)  CONFIRM  http://prdownloads.sourceforge.net/phpnuke/PHP-Nuke-5.5.tar.gz
http://www.iss.net/security_center/static/7654.php
(UNKNOWN)  XF  phpnuke-postnuke-css(7654)
http://www.securityfocus.com/bid/3609
(UNKNOWN)  BID  3609

- 漏洞信息

PHPNuke多个跨站脚本漏洞
中危 跨站脚本
2001-12-31 00:00:00 2005-10-20 00:00:00
远程  
        PHP-Nuke 5.3.1版本及之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)user.php的uname参数,(2)modules.php的ttitle、letter和file参数,(3)submit.php的subject、story和storyext参数,(4)admin.php的upload参数以及(5)friend.php的fname参数注入任意web脚本或HTML。

- 公告与补丁

        Updated versions are available:
        PostNuke Development Team PostNuke 0.62
        
        PostNuke Development Team PostNuke 0.63
        
        PostNuke Development Team PostNuke 0.64
        
        Francisco Burzi PHP-Nuke 1.0
        
        Francisco Burzi PHP-Nuke 2.5
        
        Francisco Burzi PHP-Nuke 3.0
        
        Francisco Burzi PHP-Nuke 4.0
        
        Francisco Burzi PHP-Nuke 4.3
        
        Francisco Burzi PHP-Nuke 4.4
        
        Francisco Burzi PHP-Nuke 4.4.1 a
        
        Francisco Burzi PHP-Nuke 5.0
        
        Francisco Burzi PHP-Nuke 5.0.1
        
        Francisco Burzi PHP-Nuke 5.1
        
        Francisco Burzi PHP-Nuke 5.2 a
        
        Francisco Burzi PHP-Nuke 5.2
        
        Francisco Burzi PHP-Nuke 5.3.1
        

- 漏洞信息 (21165)

PHPNuke 1.0/2.5/3.0/4.x/5.x/6.x/7.x user.php uname Parameter XSS Vulnerability (EDBID:21165)
php webapps
2001-12-03 Verified
0 Cabezon Aurélien
N/A [点击下载]
source: http://www.securityfocus.com/bid/3609/info

PHPNuke is a website creation/maintenance tool.

PHPNuke is prone to cross-site scripting attacks. It is possible to create a link to the PHPNuke user information page, 'user.php', which contains malicious script code. When the link is clicked by an unsuspecting web user, the malicious script code will be executed on the user in the context of the site running PHPNuke.

This attack may be used to steal a user's cookie-based authentication credentials for the vulnerable PHPNuke site.

PostNuke is also affected by a number of these issues.

This problem has also been reported with other scripts included in the PHPNuke package. More specifically, modules.php, upload.php, friend.php and submit.php are also vulnerable under some circumstances. Different parameters to the user.php script may also be sufficient for a cross-site scripting attack.

An additional cross-site scripting vulnerability has been reported in modules.php for PostNuke.

**It has been reported that the cross-site scripting issue affecting the 'ttitle' parameter of 'modules.php' script has been re-introduced in newer versions of the PHPNuke application. This issue is reported to affect versions 7.2 and prior. 

http://phpnukesite/user.php?op=userinfo&uname=<script>alert(document.cookie);</script>		

- 漏洞信息 (21166)

PHPNuke 1.0/2.5/3.0/4.x/5.x/6.x/7.x modules.php Multiple Parameter XSS Vulnerability (EDBID:21166)
php webapps
2001-12-03 Verified
0 Cabezon Aurélien
N/A [点击下载]
source: http://www.securityfocus.com/bid/3609/info
 
PHPNuke is a website creation/maintenance tool.
 
PHPNuke is prone to cross-site scripting attacks. It is possible to create a link to the PHPNuke user information page, 'user.php', which contains malicious script code. When the link is clicked by an unsuspecting web user, the malicious script code will be executed on the user in the context of the site running PHPNuke.
 
This attack may be used to steal a user's cookie-based authentication credentials for the vulnerable PHPNuke site.
 
PostNuke is also affected by a number of these issues.
 
This problem has also been reported with other scripts included in the PHPNuke package. More specifically, modules.php, upload.php, friend.php and submit.php are also vulnerable under some circumstances. Different parameters to the user.php script may also be sufficient for a cross-site scripting attack.
 
An additional cross-site scripting vulnerability has been reported in modules.php for PostNuke.
 
**It has been reported that the cross-site scripting issue affecting the 'ttitle' parameter of 'modules.php' script has been re-introduced in newer versions of the PHPNuke application. This issue is reported to affect versions 7.2 and prior. 

http://phpnukesite/modules.php?op=modload&name=Downloads&file=index&req=viewdownloaddetails&lid=2&ttitle=%3Cscript%3Ealert(document.location)%3C/script%3E 		

- 漏洞信息

20230
PHP-Nuke user.php uname Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

PHP-Nuke contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the 'uname' parameter upon submission to the 'user.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2001-12-03 Unknow
2001-12-03 2002-01-14

- 解决方案

Upgrade to version 5.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站