CVE-2001-1510
CVSS5.0
发布时间 :2001-12-31 00:00:00
修订时间 :2008-09-05 16:26:44
NMCOS    

[原文]Allaire JRun 2.3.3, 3.0 and 3.1 running on IIS 4.0 and 5.0, iPlanet, Apache, JRun web server (JWS), and possibly other web servers allows remote attackers to read arbitrary files and directories by appending (1) "%3f.jsp", (2) "?.jsp" or (3) "?" to the requested URL.


[CNNVD]Allaire JRun Web根目录泄露漏洞(CNNVD-200112-162)

        运行于IIS 4.0和5.0版本,iPlanet,Apache, JRun web服务器(JWS),和可能其他web服务器上的Allaire JRun 2.3.3,3.0和3.1版本存在漏洞。远程攻击者通过附加(1)"%3f.jsp", (2)"?.jsp"或者(3)"?" 到受请求的URL读取任意文件和目录。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:macromedia:jrun:2.3.3Macromedia JRun 2.3.3
cpe:/a:macromedia:jrun:3.1Macromedia JRun 3.1
cpe:/a:macromedia:jrun:3.0Macromedia JRun 3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1510
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1510
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-162
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3592
(UNKNOWN)  BID  3592
http://www.macromedia.com/v1/handlers/index.cfm?ID=22262&Method=Full
(VENDOR_ADVISORY)  ALLAIRE  MPSB01-13
http://www.iss.net/security_center/static/7623.php
(UNKNOWN)  XF  allaire-jrun-view-directory(7623)

- 漏洞信息

Allaire JRun Web根目录泄露漏洞
中危 未知
2001-12-31 00:00:00 2005-10-20 00:00:00
远程  
        运行于IIS 4.0和5.0版本,iPlanet,Apache, JRun web服务器(JWS),和可能其他web服务器上的Allaire JRun 2.3.3,3.0和3.1版本存在漏洞。远程攻击者通过附加(1)"%3f.jsp", (2)"?.jsp"或者(3)"?" 到受请求的URL读取任意文件和目录。

- 公告与补丁

        Updates are available. Please see the references for details.

- 漏洞信息

680
Allaire JRun Encoded JSP Request Arbitrary Directory Listing

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-11-27 Unknow
2001-11-27 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Allaire JRun Web Root Directory Disclosure Vulnerability
Unknown 3592
Yes No
2001-11-27 12:00:00 2009-11-03 03:27:00
Discovered by George Hedfors <george.hedfors@defcom.com> of Defcom Labs and published in Macromedia Product Security Bulletin (MPSB01-13) on November 27, 2001.

- 受影响的程序版本

Macromedia JRun 3.1
- IBM AIX 4.3
- IBM AIX 4.2
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
- RedHat Linux 6.1 sparc
- RedHat Linux 6.1 i386
- RedHat Linux 6.1 alpha
- RedHat Linux 6.0 sparc
- RedHat Linux 6.0 alpha
- RedHat Linux 6.0
- SGI IRIX 6.5
- Sun Solaris 8_sparc
- Sun Solaris 7.0
Macromedia JRun 3.0
- IBM AIX 4.3
- IBM AIX 4.2
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
- RedHat Linux 6.1 sparc
- RedHat Linux 6.1 i386
- RedHat Linux 6.1 alpha
- RedHat Linux 6.0 sparc
- RedHat Linux 6.0
- SGI IRIX 6.5
- Sun Solaris 7.0
- Sun Solaris 2.6

- 漏洞讨论

Allaire JRun is a development suite with JSP and Java Servlets for developing web applications.

Allaire JRun is prone to an information-disclosure vulnerability because it fails to handle malformed URLs properly. A remote attacker could access the contents under the webserver root directory.

Submitting a request for 'http://server/%3f.jsp' could cause JRun to reveal the contents within the web root. It's also possible to view the contents of any subdirectories along with ACL-protected resources.

The attacker could exploit this issue to obtain the source of known files residing on the host, including ASP files.

NOTE: This vulnerability was originally reported to work on Microsoft IIS hosts only, but other webservers (Apache, Jetty) have been reported vulnerable.

- 漏洞利用

Attackers can use a browser to exploit this issue.

- 解决方案

Updates are available. Please see the references for details.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站