CVE-2001-1496
CVSS7.5
发布时间 :2001-12-31 00:00:00
修订时间 :2008-09-05 16:26:42
NMCO    

[原文]Off-by-one buffer overflow in Basic Authentication in Acme Labs thttpd 1.95 through 2.20 allows remote attackers to cause a denial of service and possibly execute arbitrary code.


[CNNVD]thttpd基本认证缓冲区溢出漏洞(CNNVD-200112-237)

        Acme Labs thttpd 1.95至2.20版本的基本认证存在缓冲区溢出漏洞。远程攻击者可以利用该漏洞导致服务拒绝并可能执行代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:acme_labs:thttpd:2.0
cpe:/a:acme_labs:thttpd:2.13
cpe:/a:acme_labs:thttpd:2.0.9
cpe:/a:acme_labs:thttpd:2.18
cpe:/a:acme_labs:thttpd:2.16
cpe:/a:acme_labs:thttpd:2.12
cpe:/a:acme_labs:thttpd:2.14
cpe:/a:acme_labs:thttpd:2.0.5
cpe:/a:acme_labs:thttpd:2.0.7
cpe:/a:acme_labs:thttpd:2.20
cpe:/a:acme_labs:thttpd:2.0.2
cpe:/a:acme_labs:thttpd:2.0.6
cpe:/a:acme_labs:thttpd:2.17
cpe:/a:acme_labs:thttpd:2.15
cpe:/a:acme_labs:thttpd:2.0.1
cpe:/a:acme_labs:thttpd:2.20b
cpe:/a:acme_labs:thttpd:1.95
cpe:/a:acme_labs:thttpd:2.19
cpe:/a:acme_labs:thttpd:2.0.3
cpe:/a:acme_labs:thttpd:2.0.4
cpe:/a:acme_labs:thttpd:2.0.8
cpe:/a:acme_labs:thttpd:2.10
cpe:/a:acme_labs:thttpd:2.11

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1496
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1496
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-237
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/7595
(UNKNOWN)  XF  thttpd-basic-authentication-bo(7595)
http://www.securityfocus.com/bid/3562
(UNKNOWN)  BID  3562
http://www.securityfocus.com/archive/1/241953
(UNKNOWN)  BUGTRAQ  20011123 Re: Off-by-one vulnerability in thttpd!!!
http://www.securityfocus.com/archive/1/241310
(UNKNOWN)  BUGTRAQ  20011120 Off-by-one vulnerability in thttpd!!!

- 漏洞信息

thttpd基本认证缓冲区溢出漏洞
高危 缓冲区溢出
2001-12-31 00:00:00 2006-08-03 00:00:00
远程  
        Acme Labs thttpd 1.95至2.20版本的基本认证存在缓冲区溢出漏洞。远程攻击者可以利用该漏洞导致服务拒绝并可能执行代码。

- 公告与补丁

        Updated versions of thttpd have been made available.

- 漏洞信息

7362
thttpd Basic Authentication Feature Base-64 Encoding Overflow
Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

- 时间线

2001-11-20 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站