CVE-2001-1495
CVSS7.5
发布时间 :2001-12-31 00:00:00
修订时间 :2008-09-10 15:10:36
NMCO    

[原文]network_query.php in Network Query Tool 1.0 allows remote attackers execute arbitrary commands via shell metacharacters in the target parameter.


[CNNVD]Network查询工具执行远程命令漏洞(CNNVD-200112-255)

        Network Query Tool 1.0版本的network_query.php存在漏洞。远程攻击者可以借助目标参数的shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:freshmeat:network_query_tool:1.0
cpe:/a:freshmeat:network_query_tool_phpnuke:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1495
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1495
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-255
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/7322
(UNKNOWN)  XF  nqt-php-command-execution(7322)
http://www.securityfocus.com/bid/3455
(UNKNOWN)  BID  3455
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2001-10/0179.html
(UNKNOWN)  BUGTRAQ  20011022 [Advisory iSecureLabs] Network Query Tool remote command execution

- 漏洞信息

Network查询工具执行远程命令漏洞
高危 输入验证
2001-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Network Query Tool 1.0版本的network_query.php存在漏洞。远程攻击者可以借助目标参数的shell元字符执行任意命令。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

5676
Network Query Tool network_query.php Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Network Query Tool contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the network_query.php script not properly sanitizing shell metacharacters. With a specially crafted request, an attacker can execute arbitrary commands with the privileges of the web server.

- 时间线

2001-10-21 Unknow
2001-10-21 Unknow

- 解决方案

Upgrade to version 1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站