CVE-2001-1468
CVSS7.5
发布时间 :2001-02-07 00:00:00
修订时间 :2008-09-05 16:26:38
NMCO    

[原文]PHP remote file inclusion vulnerability in checklogin.php in phpSecurePages 0.24 and earlier allows remote attackers to execute arbitrary PHP code by modifying the cfgProgDir parameter to reference a URL on a remote web server that contains the code.


[CNNVD]phpSecurePages包括文件任意命令执行漏洞(CNNVD-200102-002)

        phpSecurePages 0.24版本及之前版本中checklogin.php存在PHP远程文件包含漏洞。远程攻击者可以通过修改cfgProgDir参数以引用远程web服务器上含代码的URL来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:secure_reality:phpsecurepages:0.15_beta
cpe:/a:secure_reality:phpsecurepages:0.14_beta
cpe:/a:secure_reality:phpsecurepages:0.19_beta
cpe:/a:secure_reality:phpsecurepages:0.23_beta
cpe:/a:secure_reality:phpsecurepages:0.13_beta
cpe:/a:secure_reality:phpsecurepages:0.24_beta
cpe:/a:secure_reality:phpsecurepages:0.22_beta
cpe:/a:secure_reality:phpsecurepages:0.18_beta
cpe:/a:secure_reality:phpsecurepages:0.12_beta
cpe:/a:secure_reality:phpsecurepages:0.11_beta
cpe:/a:secure_reality:phpsecurepages:0.16_beta
cpe:/a:secure_reality:phpsecurepages:0.20_beta
cpe:/a:secure_reality:phpsecurepages:0.21_beta
cpe:/a:secure_reality:phpsecurepages:0.17_beta

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1468
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1468
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200102-002
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/391347
(UNKNOWN)  CERT-VN  VU#391347
http://xforce.iss.net/xforce/xfdb/6774
(UNKNOWN)  XF  phpsecurepages-checklogin-execute-code(6774)
http://www.securityfocus.com/bid/2970
(UNKNOWN)  BID  2970
http://securitytracker.com/id?1001408
(UNKNOWN)  SECTRACK  1001408

- 漏洞信息

phpSecurePages包括文件任意命令执行漏洞
高危 输入验证
2001-02-07 00:00:00 2006-09-28 00:00:00
远程  
        phpSecurePages 0.24版本及之前版本中checklogin.php存在PHP远程文件包含漏洞。远程攻击者可以通过修改cfgProgDir参数以引用远程web服务器上含代码的URL来执行任意PHP代码。

- 公告与补丁

        This issue is rectified in versions 0.25beta and higher of phpSecurePages:
        phpSecurePages phpSecurePages 0.24 beta
        

- 漏洞信息

18591
phpSecurePages checklogin.php cfgProgDir Variable Arbitrary Code Execution
Remote / Network Access
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-07-02 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站