CVE-2001-1413
CVSS7.5
发布时间 :2004-12-23 00:00:00
修订时间 :2008-09-05 16:26:29
NMCOS    

[原文]Stack-based buffer overflow in the comprexx function for ncompress 4.2.4 and earlier, when used in situations that cross security boundaries (such as FTP server), may allow remote attackers to execute arbitrary code via a long filename argument.


[CNNVD]Ncompress长文件名缓冲区溢出漏洞(CNNVD-200412-095)

        ncompress 4.2.4及其以前的版本的comprexx函数存在基于堆栈的缓冲区溢出漏洞。使用于跨安全边界的情况下时(比如FTP服务器),远程攻击者借助超长文件名参数执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1413
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1413
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-095
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/176363
(VENDOR_ADVISORY)  CERT-VN  VU#176363
http://www.redhat.com/support/errata/RHSA-2004-536.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2004:536
http://security.gentoo.org/glsa/glsa-200410-08.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200410-08
http://xforce.iss.net/xforce/xfdb/10619
(VENDOR_ADVISORY)  XF  ncompress-filename-bo(10619)
http://seclists.org/lists/vuln-dev/2001/Nov/0202.html
(UNKNOWN)  VULN-DEV  20010621 New bugs, old bugs

- 漏洞信息

Ncompress长文件名缓冲区溢出漏洞
高危 缓冲区溢出
2004-12-23 00:00:00 2005-10-20 00:00:00
远程  
        ncompress 4.2.4及其以前的版本的comprexx函数存在基于堆栈的缓冲区溢出漏洞。使用于跨安全边界的情况下时(比如FTP服务器),远程攻击者借助超长文件名参数执行任意代码。

- 公告与补丁

        Gentoo Linux has released advisory GLSA 200410-08 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
         emerge sync
         emerge -pv ">=app-arch/ncompress-4.2.4-r1"
         emerge ">=app-arch/ncompress-4.2.4-r1"
        Please see the referenced advisory for further information.
        RedHat has released advisory RHSA-2004:536-05 to address this issue in RedHat Enterprise Linux operating systems. Please see the referenced advisory for further information.
        Avaya has made an advisory available (ASA-2005-015) dealing with this issue for various products. In all cases Avaya recommends that ncompress be removed from their affected software, as it is not required for execution. All Avaya hardware affected by this issue will have the vulnerable packages removed from future versions. For more information, please see the referenced security advisory.

- 漏洞信息

10636
ncompress comprexx Function Long Filename Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-11-20 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

NCompress Long Filename Buffer Overflow Vulnerability
Boundary Condition Error 11908
Yes No
2001-11-20 12:00:00 2009-07-12 09:26:00
Pavel Kankovsky disclosed this vulnerability.

- 受影响的程序版本

RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
ncompress ncompress 4.2.4
ncompress ncompress 4.2.3
ncompress ncompress 4.2.2
ncompress ncompress 4.2.1
ncompress ncompress 4.1
ncompress ncompress 4.0
Gentoo Linux
Avaya S8710 R2.0.1
Avaya S8710 R2.0.0
Avaya S8700 R2.0.1
Avaya S8700 R2.0.0
Avaya S8500 R2.0.1
Avaya S8500 R2.0.0
Avaya S8300 R2.0.1
Avaya S8300 R2.0.0
Avaya Integrated Management
Avaya CVLAN

- 漏洞讨论

It is reported that ncompress is susceptible to a buffer overflow vulnerability. This issue is due to a failure of the application to properly bounds-check user-supplied data prior to copying it into a fixed-size memory buffer.

While this vulnerability isn't inherently dangerous from the command line, as the executable is not setuid, it could allow attackers with access to remote applications that utilize ncompress, to execute arbitrary code on the targeted server.

Versions 4.2.4 and earlier of ncompress are reportedly vulnerable to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Gentoo Linux has released advisory GLSA 200410-08 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
emerge sync
emerge -pv ">=app-arch/ncompress-4.2.4-r1"
emerge ">=app-arch/ncompress-4.2.4-r1"
Please see the referenced advisory for further information.

RedHat has released advisory RHSA-2004:536-05 to address this issue in RedHat Enterprise Linux operating systems. Please see the referenced advisory for further information.

Avaya has made an advisory available (ASA-2005-015) dealing with this issue for various products. In all cases Avaya recommends that ncompress be removed from their affected software, as it is not required for execution. All Avaya hardware affected by this issue will have the vulnerable packages removed from future versions. For more information, please see the referenced security advisory.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站