CVE-2001-1402
CVSS7.5
发布时间 :2001-09-10 00:00:00
修订时间 :2016-10-17 22:15:09
NMCO    

[原文]Bugzilla before 2.14 does not properly escape untrusted parameters, which could allow remote attackers to conduct unauthorized activities via cross-site scripting (CSS) and possibly SQL injection attacks on (1) the product or output form variables for reports.cgi, (2) the voteon, bug_id, and user variables for showvotes.cgi, (3) an invalid email address in createaccount.cgi, (4) an invalid ID in showdependencytree.cgi, (5) invalid usernames and other fields in process_bug.cgi, and (6) error messages in buglist.cgi.


[CNNVD]Bugzilla 跨站脚本漏洞(CNNVD-200109-033)

        Bugzilla 2.14之前版本不能正确避免不信任参数,远程攻击者可以通过跨站脚本(CSS)和可能的在(1)reports.cgi中的产品或输出表单变量,(2)showvotes.cgi中的voteon,bug_id,以及用户变量,(3)createaccount.cgi中无效的电子邮件地址,(4)showdependencytree.cgi中无效的ID ,(5)process_bug.cgi中无效的用户名和其他领域,(6)buglist.cgi中的错误消息上的SQL注入攻击进行未授权的活动。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:bugzilla:2.6Mozilla Bugzilla 2.6
cpe:/a:mozilla:bugzilla:2.10Mozilla Bugzilla 2.10
cpe:/a:mozilla:bugzilla:2.12Mozilla Bugzilla 2.12
cpe:/a:mozilla:bugzilla:2.8Mozilla Bugzilla 2.8
cpe:/a:mozilla:bugzilla:2.14Mozilla Bugzilla 2.14
cpe:/a:mozilla:bugzilla:2.4Mozilla Bugzilla 2.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1402
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1402
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200109-033
(官方数据源) CNNVD

- 其它链接及资源

http://bugzilla.mozilla.org/show_bug.cgi?id=38854
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=38854
http://bugzilla.mozilla.org/show_bug.cgi?id=38855
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=38855
http://bugzilla.mozilla.org/show_bug.cgi?id=38859
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=38859
http://bugzilla.mozilla.org/show_bug.cgi?id=39536
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=39536
http://bugzilla.mozilla.org/show_bug.cgi?id=87701
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=87701
http://bugzilla.mozilla.org/show_bug.cgi?id=95235
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=95235
http://marc.info/?l=bugtraq&m=99912899900567
(UNKNOWN)  BUGTRAQ  20010829 Security Advisory for Bugzilla v2.13 and older
http://www.redhat.com/support/errata/RHSA-2001-107.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2001:107

- 漏洞信息

Bugzilla 跨站脚本漏洞
高危 跨站脚本
2001-09-10 00:00:00 2005-10-20 00:00:00
远程  
        Bugzilla 2.14之前版本不能正确避免不信任参数,远程攻击者可以通过跨站脚本(CSS)和可能的在(1)reports.cgi中的产品或输出表单变量,(2)showvotes.cgi中的voteon,bug_id,以及用户变量,(3)createaccount.cgi中无效的电子邮件地址,(4)showdependencytree.cgi中无效的ID ,(5)process_bug.cgi中无效的用户名和其他领域,(6)buglist.cgi中的错误消息上的SQL注入攻击进行未授权的活动。

- 公告与补丁

        

- 漏洞信息

6373
Bugzilla createaccount.cgi login Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Bugzilla contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the login variable upon submission to the createaccount.cgi script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2001-08-29 Unknow
2001-08-29 Unknow

- 解决方案

Upgrade to version 2.14 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站