发布时间 :2001-10-18 00:00:00
修订时间 :2016-10-17 22:14:47

[原文]OpenSSH before 2.9.9, while using keypairs and multiple keys of different types in the ~/.ssh/authorized_keys2 file, may not properly handle the "from" option associated with a key, which could allow remote attackers to login from unauthorized IP addresses.


        OpenSSH 2.9.9之前版本在使用~/.ssh/authorized_keys2文件中的keypair和多个不同类型的密钥时可能不正确地处理与密钥有关的"from"选项,远程攻击者可以从未认证的IP地址登录。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  IMMUNIX  IMNX-2001-70-034-01
(UNKNOWN)  BUGTRAQ  20010926 OpenSSH Security Advisory (adv.option)
(UNKNOWN)  BID  3369
(UNKNOWN)  XF  openssh-access-control-bypass(7179)

- 漏洞信息

高危 其他
2001-10-18 00:00:00 2006-03-28 00:00:00
        OpenSSH 2.9.9之前版本在使用~/.ssh/authorized_keys2文件中的keypair和多个不同类型的密钥时可能不正确地处理与密钥有关的"from"选项,远程攻击者可以从未认证的IP地址登录。

- 公告与补丁

        Upgrades are available.
        RedHat openssh-askpass-2.1.1p4-1.i386.rpm
        RedHat openssh-clients-2.1.1p4-1.i386.rpm
        RedHat openssh-server-2.1.1p4-1.i386.rpm
        RedHat openssh-2.9p2-7.i386.rpm
        RedHat openssh-askpass-gnome-2.9p2-7.i386.rpm
        RedHat openssh-2.5.2p2-5.i386.rpm
        RedHat openssh-askpass-2.9p2-7.i386.rpm
        RedHat openssh-2.1.1p4-1.i386.rpm
        RedHat openssh-askpass-gnome-2.1.1p4-1.i386.rpm
        RedHat openssh-server-2.5.2p2-5.i386.rpm
        RedHat openssh-askpass-gnome-2.5.2p2-5.i386.rpm
        RedHat openssh-clients-2.9p2-7.i386.rpm
        RedHat openssh-clients-2.5.2p2-5.i386.rpm
        RedHat openssh-server-2.9p2-7.i386.rpm
        RedHat openssh-askpass-2.5.2p2-5.i386.rpm
        OpenSSH OpenSSH 2.5
        OpenSSH OpenSSH 2.5.1
        OpenSSH OpenSSH 2.5.2
        OpenSSH OpenSSH 2.9
        OpenSSH OpenSSH 2.9 p2

- 漏洞信息

OpenSSH Multiple Key Type ACL Bypass
Local Access Required, Remote / Network Access Authentication Management, Cryptographic
Loss of Confidentiality
Exploit Public

- 漏洞描述

In OpenSSH versions 2.5 to 2.9, it is possible to circumvent source address based ACLs if multiple different types of cryptographic keys are used for authentication and the 'from=' option is used to restrict access by IP address. An attacker can use the ACL settings on the second key for access via either key, and perhaps gain access to this host from an unapproved IP address. Note: Valid login credentials such as a username and password are still required.

- 时间线

2001-09-26 Unknow
2001-09-26 Unknow

- 解决方案

Upgrade to version 2.9.9 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by applying the vendor-supplied patch, or by configuring your system in such a way as to avoid using the 'from=' key file option in combination with both RSA and DSA keys.

- 相关参考

- 漏洞作者

Unknown or Incomplete