CVE-2001-1374
CVSS7.2
发布时间 :2001-07-19 00:00:00
修订时间 :2008-09-05 16:26:23
NMCO    

[原文]expect before 5.32 searches for its libraries in /var/tmp before other directories, which could allow local users to gain root privileges via a Trojan horse library that is accessed by mkpasswd.


[CNNVD]TCL/TK expect不安全的库搜索路径漏洞(CNNVD-200107-124)

        
        Tcl是一种流行的命令编程语言,可以很方便地利用它来向一些交互程序发布命令。它还包括一个库软件包,里面包括Tcl语言解释器、实现内置Tcl命令的例程、以及一些扩展功能。TK是Tcl的一个扩展,用来为程序员提供一个与X11 Windows系统的编程接口。一些Linux系统带的Tcl/Tk开发环境中含有一些应用程序:tcl、tk、tix、tclX、expect和itcl。
        Tcl/tk软件包中所带的expect应用程序5.32之前版本在搜索自己的库文件时采用了不安全的搜索路径,可能允许本地用户提升权限。
        expect在搜索其它目录之前会首先在一个临时目录/var/tmp下搜索自己的库libexpect5.31.so,如果这个目录下库文件存在且有效,Expect就会加载这个库。本地用户可以在该目录下创建一个木马库程序。当其他用户(例如root用户)调用任何使用expect的程序时,就可能执行攻击者指定的任意代码。某些Linux系统所带的mkpasswd程序就使用expect来为用户创建随机口令,当root用户调用mkpasswd时,攻击者就可能获取本地root权限。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:conectiva:linux:7.0Conectiva Conectiva Linux 7.0
cpe:/a:don_libes:expect:4
cpe:/a:don_libes:expect:5.20
cpe:/a:don_libes:expect:5.5
cpe:/a:don_libes:expect:5.26
cpe:/a:don_libes:expect:5.23
cpe:/a:don_libes:expect:5.29
cpe:/a:don_libes:expect:3
cpe:/a:don_libes:expect:5.15
cpe:/a:don_libes:expect:2
cpe:/a:don_libes:expect:5.17
cpe:/a:don_libes:expect:5.28
cpe:/a:don_libes:expect:5.27
cpe:/a:don_libes:expect:5.12
cpe:/a:don_libes:expect:5.24
cpe:/a:don_libes:expect:5.1
cpe:/a:don_libes:expect:5.22
cpe:/a:don_libes:expect:5.7
cpe:/a:don_libes:expect:5.6
cpe:/a:don_libes:expect:5.11
cpe:/a:don_libes:expect:5.19
cpe:/o:conectiva:linux:6.0Conectiva Conectiva Linux 6.0
cpe:/a:don_libes:expect:5.4
cpe:/a:don_libes:expect:5.25
cpe:/a:don_libes:expect:5.21
cpe:/a:don_libes:expect:5.3
cpe:/a:don_libes:expect:5.8
cpe:/a:don_libes:expect:5.0
cpe:/a:don_libes:expect:5.16
cpe:/a:don_libes:expect:5.18
cpe:/a:don_libes:expect:5.9
cpe:/a:don_libes:expect:5.31
cpe:/a:don_libes:expect:5.13
cpe:/a:don_libes:expect:5.10
cpe:/a:don_libes:expect:5.30
cpe:/a:don_libes:expect:0
cpe:/a:don_libes:expect:5.2
cpe:/o:redhat:linux:7.0Red Hat Linux 7.0
cpe:/a:don_libes:expect:5.14
cpe:/a:don_libes:expect:1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1374
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1374
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-124
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/6870.php
(VENDOR_ADVISORY)  XF  expect-insecure-library-search(6870)
http://www.securityfocus.com/bid/3074
(VENDOR_ADVISORY)  BID  3074
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=28224
(UNKNOWN)  CONFIRM  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=28224
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=22187
(UNKNOWN)  CONFIRM  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=22187
http://www.redhat.com/support/errata/RHSA-2002-148.html
(UNKNOWN)  REDHAT  RHSA-2002:148
http://www.mandrakesoft.com/security/advisories?name=MDKSA-2002:060
(UNKNOWN)  MANDRAKE  MDKSA-2002:060
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000409
(UNKNOWN)  CONECTIVA  CLA-2001:409

- 漏洞信息

TCL/TK expect不安全的库搜索路径漏洞
高危 未知
2001-07-19 00:00:00 2006-09-05 00:00:00
本地  
        
        Tcl是一种流行的命令编程语言,可以很方便地利用它来向一些交互程序发布命令。它还包括一个库软件包,里面包括Tcl语言解释器、实现内置Tcl命令的例程、以及一些扩展功能。TK是Tcl的一个扩展,用来为程序员提供一个与X11 Windows系统的编程接口。一些Linux系统带的Tcl/Tk开发环境中含有一些应用程序:tcl、tk、tix、tclX、expect和itcl。
        Tcl/tk软件包中所带的expect应用程序5.32之前版本在搜索自己的库文件时采用了不安全的搜索路径,可能允许本地用户提升权限。
        expect在搜索其它目录之前会首先在一个临时目录/var/tmp下搜索自己的库libexpect5.31.so,如果这个目录下库文件存在且有效,Expect就会加载这个库。本地用户可以在该目录下创建一个木马库程序。当其他用户(例如root用户)调用任何使用expect的程序时,就可能执行攻击者指定的任意代码。某些Linux系统所带的mkpasswd程序就使用expect来为用户创建随机口令,当root用户调用mkpasswd时,攻击者就可能获取本地root权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 不要运行任何调用expect的程序,例如mkpasswd。
        厂商补丁:
        Conectiva
        ---------
        Conectiva已经为此发布了一个安全公告(CLA-2001:409)以及相应补丁:
        CLA-2001:409:Insecure runtime library search path
        链接:
        http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000409

        补丁下载:
        tp://atualizacoes.conectiva.com.br/6.0/SRPMS/tcltk-8.3.2-2U60_2cl.src.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/tcl-8.3.2-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/tix-4.1.0.6.1-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/itcl-3.1.0-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/tcllib-0.4-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/tk-8.3.2-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/tclx-8.3.2-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/6.0/RPMS/expect-5.32-2U60_2cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/SRPMS/tcltk-8.3.3-4U70_1cl.src.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tix-demos-4.1.0.6.1-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/expect-devel-5.32-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/expect-5.32-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/expect-devel-static-5.32-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/itcl-iwidgets2.2.0-demos-3.1.0-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tix-4.1.0.6.1-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tclx-devel-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tk-devel-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tk-devel-static-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tclx-devel-static-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/itcl-devel-static-3.1.0-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tclx-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tix-devel-static-4.1.0.6.1-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tclx-helpfiles-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/itcl-3.1.0-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tcl-devel-static-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tk-demos-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/itcl-devel-3.1.0-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tcllib-0.8-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tcl-devel-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tk-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tcl-8.3.3-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/tix-devel-4.1.0.6.1-4U70_1cl.i386.rpm
        ftp://atualizacoes.conectiva.com.br/7.0/RPMS/itcl-iwidgets-demos-3.1.0-4U70_1cl.i386.rpm
        Conectiva Linux version 6.0及以上版本的用户可以使用apt进行RPM包的更新:
        - 把以下的文本行加入到/etc/apt/sources.list文件中:
        
        rpm [cncbr] ftp://atualizacoes.conectiva.com.br 6.0/conectiva updates
        (如果你不是使用6.0版本,用合适的版本号代替上面的6.0)
        - 执行: apt-get update
        - 更新以后,再执行: apt-get upgrade
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2002:148-06)以及相应补丁:
        RHSA-2002:148-06:Updated Tcl/Tk packages fix local vulnerability
        链接:https://www.redhat.com/support/errata/RHSA-2002-148.html
        补丁下载:
        Red Hat Linux 7.0:
        SRPMS:
        ftp://updates.redhat.com/7.0/en/os/SRPMS/tcltk-8.3.3-69.src.rpm
        alpha:
        ftp://updates.redhat.com/7.0/en/os/alpha/expect-5.32.2-69.alpha.rpm
        ftp://updates.redhat.com/7.0/en/os/alpha/itcl-3.2-69.alpha.rpm
        ftp://updates.redhat.com/7.0/en/os/alpha/tcl-8.3.3-69.alpha.rpm
        ftp://updates.redhat.com/7.0/en/os/alpha/tcllib-1.0-69.alpha.rpm
        ftp://updates

- 漏洞信息

5428
expect mkpasswd Path Variable Arbitrary Program Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站