CVE-2001-1352
CVSS7.5
发布时间 :2001-12-27 00:00:00
修订时间 :2016-10-17 22:14:37
NMCO    

[原文]Cross-site scripting vulnerability in Namazu 2.0.9 and earlier allows remote attackers to execute arbitrary Javascript as other web users via an error message that is returned when an invalid index file is specified in the idxname parameter.


[CNNVD]Namazu跨站脚本漏洞(CNNVD-200112-140)

        Namazu 2.0.9及其之前版本存在跨站脚本漏洞。当在idxname参数中指定一个无效的索引文件时,远程攻击者借助返回的一个错误消息像其他用户一样执行任意Javascript。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1352
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1352
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-140
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=100947261916155&w=2
(UNKNOWN)  BUGTRAQ  20011227 Re: [RHSA-2001:162-04] Updated namazu packages are available
http://marc.info/?l=bugtraq&m=101060476404565&w=2
(UNKNOWN)  REDHAT  RHSA-2001:179
http://marc.info/?l=bugtraq&m=101068116016472&w=2
(UNKNOWN)  BUGTRAQ  20020109 Details on the updated namazu packages that are available
http://xforce.iss.net/xforce/xfdb/7875
(VENDOR_ADVISORY)  XF  linux-namazu-css(7875)

- 漏洞信息

Namazu跨站脚本漏洞
高危 跨站脚本
2001-12-27 00:00:00 2005-09-14 00:00:00
远程  
        Namazu 2.0.9及其之前版本存在跨站脚本漏洞。当在idxname参数中指定一个无效的索引文件时,远程攻击者借助返回的一个错误消息像其他用户一样执行任意Javascript。

- 公告与补丁

        

- 漏洞信息

5691
Namazu Error Message XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

Namazu 2.0.9 contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the idxname parameter upon submission to the namazu script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2001-12-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站