CVE-2001-1294
CVSS5.0
发布时间 :2001-08-22 00:00:00
修订时间 :2008-09-10 15:10:11
NMCOS    

[原文]Buffer overflow in A-V Tronics Inetserv 3.2.1 and earlier allows remote attackers to cause a denial of service (crash) in the Webmail interface via a long username and password.


[CNNVD]A-V Tronics InetServ Webmail认证缓冲区溢出漏洞(CNNVD-200108-122)

        A-V Tronics Inetserv 3.2.1及其早期版本存在缓冲区远程漏洞。远程攻击者可以借助超长用户名和密码导致Webmail 接口服务拒绝(崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:avtronics:inetserv:3.1.1
cpe:/a:avtronics:inetserv:3.0
cpe:/a:avtronics:inetserv:3.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1294
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1294
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200108-122
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/7022.php
(VENDOR_ADVISORY)  XF  inetserv-webmail-bo(7022)
http://www.securityfocus.com/bid/3224
(UNKNOWN)  BID  3224
http://www.ntbugtraq.com/default.asp?pid=36&sid=1&A2=ind0001&L=ntbugtraq&F=P&S=&P=4592
(UNKNOWN)  NTBUGTRAQ  20000117 Remote Buffer Exploit - InetServ 3.0

- 漏洞信息

A-V Tronics InetServ Webmail认证缓冲区溢出漏洞
中危 缓冲区溢出
2001-08-22 00:00:00 2005-10-20 00:00:00
远程  
        A-V Tronics Inetserv 3.2.1及其早期版本存在缓冲区远程漏洞。远程攻击者可以借助超长用户名和密码导致Webmail 接口服务拒绝(崩溃)。

- 公告与补丁

        The vendor has addressed this issue in version 3.2.3.
        A-V Tronics InetServ 3.0
        
        A-V Tronics InetServ 3.1.1
        
        A-V Tronics InetServ 3.2.1
        

- 漏洞信息

14232
A-V Tronics Inetserv Webmail Interface Username Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in A-V Tronics: InetServ. The Webmail interface fails to verify the length of the 'Username' and 'Password' fields resulting in a buffer overflow. With a specially crafted request, an attacker can cause denial of service via network, execution of arbitrary code via network, or root access via network resulting in a loss of confidentiality, integrity, and availability.

- 时间线

2001-08-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.2.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

A-V Tronics InetServ Webmail Authentication Buffer Overflow Vulnerability
Boundary Condition Error 3224
Yes No
2001-08-22 12:00:00 2009-07-11 07:56:00
This vulnerability was submitted to BugTraq on August 22nd, 2001 by SNS Research <vuln-dev@greyhack.com>.

- 受影响的程序版本

A-V Tronics InetServ 3.2.1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
- Microsoft Windows 95 SR2
- Microsoft Windows 98 SP1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
A-V Tronics InetServ 3.1.1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
- Microsoft Windows 95 SR2
- Microsoft Windows 98 SP1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
A-V Tronics InetServ 3.0
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
- Microsoft Windows 95 SR2
- Microsoft Windows 98 SP1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
A-V Tronics InetServ 3.2.3
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
- Microsoft Windows 98 SP1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1

- 不受影响的程序版本

A-V Tronics InetServ 3.2.3
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
- Microsoft Windows 98 SP1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1

- 漏洞讨论

A-V Tronics InetServ is a freeware server for Microsoft Windows systems. It offers functionality for POP3, SMTP, telnet, webmail and other services.

An exploitable buffer overflow exists in the webmail interface of Inetserver.

The buffer overflow will occur if the Username/Password fields are each filled with an excessive number of bytes(140+). At the very minimum this can cause InetServ to crash, denying whatever services the software has been enabled to provide(telnet, SMTP, POP3, etc.). However, a window of opportunity exists for remote attackers to execute arbitrary code on the host(with the privileges of the server), possibly allowing the attacker to gain local access to the host.

It should be noted that the webmail interface is an optional feature of A-V Tronics InetServ, and is not enabled by default.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has addressed this issue in version 3.2.3.


A-V Tronics InetServ 3.0

A-V Tronics InetServ 3.1.1

A-V Tronics InetServ 3.2.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站