发布时间 :2001-10-12 00:00:00
修订时间 :2008-09-10 15:10:10

[原文]Ipswitch IMail 7.04 and earlier stores a user's session ID in a URL, which could allow remote attackers to hijack sessions by obtaining the URL, e.g. via an HTML email that causes the Referrer to be sent to a URL under the attacker's control.

[CNNVD]Ipswitch Imail用户邮箱泄露漏洞(CNNVD-200110-044)

        Ipswitch IMail 7.04及其早期版本在URL中存储用户的session ID,远程攻击者通过获取URL拦截sessions,比如借助导致发送Referrer到攻击者控制下URL的HTML电子邮件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ipswitch:imail:6.0.6Ipswitch IMail 6.0.6
cpe:/a:ipswitch:imail:7.0.4Ipswitch IMail 7.0.4
cpe:/a:ipswitch:imail:6.0.2Ipswitch IMail 6.0.2

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  BUGTRAQ  20020310 IMail Account hijack through the Web Interface
(UNKNOWN)  BUGTRAQ  20011011 Ipswitch Imail 7.04 vulnerabilities
(UNKNOWN)  BID  3432

- 漏洞信息

Ipswitch Imail用户邮箱泄露漏洞
高危 访问验证错误
2001-10-12 00:00:00 2005-10-20 00:00:00
        Ipswitch IMail 7.04及其早期版本在URL中存储用户的session ID,远程攻击者通过获取URL拦截sessions,比如借助导致发送Referrer到攻击者控制下URL的HTML电子邮件。

- 公告与补丁

        Ipswitch has released a Hotfix which rectifies this issue. It should be noted that user's are required to have at least IMail 7.04 in order to successfully install this Hotfix.
        Ipswitch IMail 7.0.4

- 漏洞信息

Ipswitch IMail Web Interface URI Referer Session Token Disclosure
Remote / Network Access
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2001-10-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 7.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete