CVE-2001-1270
CVSS2.1
发布时间 :2001-07-12 00:00:00
修订时间 :2008-09-05 16:26:07
NMCOS    

[原文]Directory traversal vulnerability in the console version of PKZip (pkzipc) 4.00 and earlier allows attackers to overwrite arbitrary files during archive extraction with the -rec (recursive) option via a .. (dot dot) attack on the archived files.


[CNNVD]PKWare PKZip敌对目标路径漏洞(CNNVD-200107-077)

        PKZip (pkzipc) 4.00及其早期的控制台版本存在目录遍历漏洞。远程攻击者可以在提取存档期间借助在存档文件上的..(点 点)攻击覆盖具有-rec(递归)选项的任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1270
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1270
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-077
(官方数据源) CNNVD

- 其它链接及资源

http://online.securityfocus.com/archive/1/196445
(VENDOR_ADVISORY)  BUGTRAQ  20010712 SECURITY.NNOV: directory traversal and path globing in multiple archivers
http://www.security.nnov.ru/advisories/archdt.asp
(VENDOR_ADVISORY)  MISC  http://www.security.nnov.ru/advisories/archdt.asp

- 漏洞信息

PKWare PKZip敌对目标路径漏洞
低危 路径遍历
2001-07-12 00:00:00 2005-10-20 00:00:00
远程  
        PKZip (pkzipc) 4.00及其早期的控制台版本存在目录遍历漏洞。远程攻击者可以在提取存档期间借助在存档文件上的..(点 点)攻击覆盖具有-rec(递归)选项的任意文件。

- 公告与补丁

        Users should contact the vendor to determine if a fixed version is available for their operating system.
        FreeBSD has released upgrades. Users are advised to upgrade their Ports
        collection and reinstall the affected port.

- 漏洞信息

8974
PKZip pkzipc -rec Option Double Dot Arbitrary File Overwrite

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-07-02 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PKWare PKZip Hostile Destination Path Vulnerability
Access Validation Error 5933
Yes No
2001-07-12 12:00:00 2009-07-11 06:06:00
Reported by 3APA3A <3APA3A@security.nnov.ru>.

- 受影响的程序版本

PKWare PKZip 4.0
PKWare PKZip 2.5.1
PKWare PKZip 2.5
- FreeBSD FreeBSD 5.0
- FreeBSD FreeBSD 4.6 -STABLE
- FreeBSD FreeBSD 4.6 -RELEASE
- FreeBSD FreeBSD 4.6
- FreeBSD FreeBSD 4.5 -STABLE
- FreeBSD FreeBSD 4.5 -RELEASE
- FreeBSD FreeBSD 4.5
- FreeBSD FreeBSD 4.4 -STABLE
- FreeBSD FreeBSD 4.4
PKWare PKZip 5.5
PKWare PKZip 5.0

- 不受影响的程序版本

PKWare PKZip 5.5
PKWare PKZip 5.0

- 漏洞讨论

PKWare PKZip is prone to a vulnerability in the handling of pathnames for archived files.

By specifying a path for an archived item which points outside the expected directory scope, the creator of the archive can cause the file to be extracted to arbitrary locations on the filesystem - including paths containing system binaries and other sensitive or confidential information.

This can be used to create or overwrite binaries in any desired location. Properly exploited, this grants the archive creator an elevation of privileges.

This issue is reported to exist in the console version of the software (pkzipc) and occurs when the recursive (-rec) command line option is specified during decompression.

- 漏洞利用

There is no exploit required.

- 解决方案

Users should contact the vendor to determine if a fixed version is available for their operating system.

FreeBSD has released upgrades. Users are advised to upgrade their Ports
collection and reinstall the affected port.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站