发布时间 :2001-07-12 00:00:00
修订时间 :2010-05-25 00:10:13

[原文]Info-ZIP UnZip 5.42 and earlier allows attackers to overwrite arbitrary files during archive extraction via filenames in the archive that begin with the '/' (slash) character.

[CNNVD]Info-ZIP UnZip敌对目标路径漏洞(CNNVD-200107-074)

        Info-ZIP UnZip 5.42及其早期版本存在漏洞。远程攻击者可以在提取存档期间借助以'/' (斜线)字符开始的档案中的文件名覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  BUGTRAQ  20010712 SECURITY.NNOV: directory traversal and path globing in multiple archivers

- 漏洞信息

Info-ZIP UnZip敌对目标路径漏洞
低危 访问验证错误
2001-07-12 00:00:00 2005-10-20 00:00:00
        Info-ZIP UnZip 5.42及其早期版本存在漏洞。远程攻击者可以在提取存档期间借助以'/' (斜线)字符开始的档案中的文件名覆盖任意文件。

- 公告与补丁

        Gentoo Linux has released an advisory. It is highly suggested that users who have installed app-arch/unzip-5.42-r1 and earlier update their systems by issuing the following commands:
        emerge rsync
        emerge unzip
        emerge clean
        HP has released an advisory for HP Secure OS Software for Linux Release 1.0 instructing users to install the packages listed under Red Hat Linux 7.1 i386 in the attached Red Hat advisory (RHSA-2002:096).
        FreeBSD has released upgrades. Users are advised to upgrade their Ports
        collection and reinstall the affected port.
        Fixes are available:
        Info-ZIP UnZip 5.42

- 漏洞信息

UnZip Single Slash Arbitrary File Overwrite
Local Access Required Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

UnZip contains a flaw that may allow a malicious user to overwrite arbitrary files. The issue is triggered when an archived file contains single slash ('/') sequences in the file name, which could allow a malicious user to overwrite arbitrary files on the system resulting in a loss of integrity.

- 时间线

2001-07-02 Unknow
2001-07-02 2002-02-20

- 解决方案

Upgrade to version 5.50 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者