CVE-2001-1234
CVSS7.5
发布时间 :2001-10-02 00:00:00
修订时间 :2008-09-05 16:26:01
NMCO    

[原文]Bharat Mediratta Gallery PHP script before 1.2.1 allows remote attackers to execute arbitrary code by including files from remote web sites via an HTTP request that modifies the includedir variable.


[CNNVD]Bharat Mediratta Gallery PHP script代码执行漏洞(CNNVD-200110-004)

        Bharat Mediratta Gallery PHP script 1.2.1之前的版本存在漏洞。远程攻击者可以通过远程web网站的包含文件,使用修改includedir变量的HTTP请求执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gallery_project:gallery:1.1
cpe:/a:gallery_project:gallery:1.2
cpe:/a:gallery_project:gallery:1.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1234
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1234
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200110-004
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/7215.php
(VENDOR_ADVISORY)  XF  php-includedir-code-execution(7215)
http://www.securityfocus.com/bid/3397
(VENDOR_ADVISORY)  BID  3397
http://prdownloads.sourceforge.net/gallery/gallery-1.2.5.tar.gz
(UNKNOWN)  CONFIRM  http://prdownloads.sourceforge.net/gallery/gallery-1.2.5.tar.gz
http://www.osvdb.org/1967
(UNKNOWN)  OSVDB  1967
http://archives.neohapsis.com/archives/bugtraq/2001-10/0012.html
(UNKNOWN)  BUGTRAQ  20011002 results of semi-automatic source code audit

- 漏洞信息

Bharat Mediratta Gallery PHP script代码执行漏洞
高危 未知
2001-10-02 00:00:00 2006-08-17 00:00:00
远程  
        Bharat Mediratta Gallery PHP script 1.2.1之前的版本存在漏洞。远程攻击者可以通过远程web网站的包含文件,使用修改includedir变量的HTTP请求执行任意代码。

- 公告与补丁

        

- 漏洞信息

1967
Bharat Mediratta Gallery includedir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

Gallery contains a flaw that may allow a remote attacker to execute arbitrary commands or code. The issue is due to the program not properly sanitizing user input supplied to the 'includedir' parameter. This may allow an attacker to include a file from a third-party remote host that contains commands or code that will be executed by the vulnerable script with the same privileges as the web server.

- 时间线

2001-10-02 2001-10-02
2001-10-02 Unknow

- 解决方案

Upgrade to version 1.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站