CVE-2001-1230
CVSS7.5
发布时间 :2001-03-13 00:00:00
修订时间 :2016-10-17 22:14:22
NMCOS    

[原文]Buffer overflows in Icecast before 1.3.10 allow remote attackers to cause a denial of service (crash) and execute arbitrary code.


[CNNVD]Icecast远程缓冲区溢出漏洞(CNNVD-200103-075)

        Icecast 1.3.10之前的版本存在缓冲区溢出漏洞。远程攻击者可以利用该漏洞导致服务拒绝(崩溃)并且可以执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1230
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1230
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200103-075
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=98455723123298&w=2
(UNKNOWN)  BUGTRAQ  20010313 More Icecast remote vulnerabilities
http://www.debian.org/security/2001/dsa-089
(VENDOR_ADVISORY)  DEBIAN  DSA-089
http://www.redhat.com/support/errata/RHSA-2002-063.html
(UNKNOWN)  REDHAT  RHSA-2002:063

- 漏洞信息

Icecast远程缓冲区溢出漏洞
高危 缓冲区溢出
2001-03-13 00:00:00 2005-10-20 00:00:00
远程  
        Icecast 1.3.10之前的版本存在缓冲区溢出漏洞。远程攻击者可以利用该漏洞导致服务拒绝(崩溃)并且可以执行任意代码。

- 公告与补丁

        Fixes are available:
        Icecast Icecast 1.0 .0
        
        Icecast Icecast 1.1 .0
        
        Icecast Icecast 1.1.1
        
        Icecast Icecast 1.1.2
        
        Icecast Icecast 1.1.3
        
        Icecast Icecast 1.1.4
        
        Icecast Icecast 1.3 .0
        
        Icecast Icecast 1.3.5
        
        Icecast Icecast 1.3.5 -1
        
        Icecast Icecast 1.3.7 -1
        
        Icecast Icecast 1.3.7
        
        Icecast Icecast 1.3.8
        
        Icecast Icecast 1.3.8 beta2
        
        Icecast Icecast 1.3.9 -1
        
        Icecast Icecast 1.3.9
        
        Icecas

- 漏洞信息

10444
Icecast Multiple Unspecified Remote Overflows
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-03-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Icecast Remote Buffer Overflow Vulnerability
Boundary Condition Error 4743
Yes No
2001-03-13 12:00:00 2009-07-11 12:46:00
Discovery of these issues is credited to Andreas Hasenack <andreas@conectiva.com.br>. Matt Messier <mmessier@prilnari.com> verified that these issues are remotely exploitable.

- 受影响的程序版本

Icecast Icecast 1.3.9 -2
Icecast Icecast 1.3.9 -1
Icecast Icecast 1.3.9
+ Conectiva Linux 6.0
+ Conectiva Linux 5.1
+ Conectiva Linux 5.0
+ Conectiva Linux 4.2
+ Conectiva Linux 4.1
Icecast Icecast 1.3.8 beta2
Icecast Icecast 1.3.8
Icecast Icecast 1.3.7 -1
Icecast Icecast 1.3.7
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
Icecast Icecast 1.3.5 -1
Icecast Icecast 1.3.5
Icecast Icecast 1.3 .0
Icecast Icecast 1.1.4
Icecast Icecast 1.1.3
Icecast Icecast 1.1.2
Icecast Icecast 1.1.1
Icecast Icecast 1.1 .0
Icecast Icecast 1.0 .0
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Debian Linux 2.2
Icecast Icecast 1.3.10 -1
Icecast Icecast 1.3 .10
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1

- 不受影响的程序版本

Icecast Icecast 1.3.10 -1
Icecast Icecast 1.3 .10
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1

- 漏洞讨论

Icecast is a freely available, open source streaming audio server. Icecast is available for the Unix, Linux, and Microsoft Windows platforms.

Icecast is prone to a number of remotely exploitable buffer overflow conditions. This may enable an attacker to execute code with the privileges of the Icecast server (vulnerable versions normally run as root) or potentially deny service to legitimate users.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Fixes are available:


Icecast Icecast 1.0 .0

Icecast Icecast 1.1 .0

Icecast Icecast 1.1.1

Icecast Icecast 1.1.2

Icecast Icecast 1.1.3

Icecast Icecast 1.1.4

Icecast Icecast 1.3 .0

Icecast Icecast 1.3.5

Icecast Icecast 1.3.5 -1

Icecast Icecast 1.3.7 -1

Icecast Icecast 1.3.7

Icecast Icecast 1.3.8

Icecast Icecast 1.3.8 beta2

Icecast Icecast 1.3.9 -1

Icecast Icecast 1.3.9

Icecast Icecast 1.3.9 -2

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站