CVE-2001-1222
CVSS5.0
发布时间 :2002-03-25 00:00:00
修订时间 :2008-09-05 16:25:59
NMCOS    

[原文]Plesk Server Administrator (PSA) 1.0 allows remote attackers to obtain PHP source code via an HTTP request containing the target's IP address and a valid account name for the domain.


[CNNVD]Plesk Server Administrator 源代码泄露漏洞(CNNVD-200203-096)

        
        Plesk Server Administrator是一款基于Web的Web服务器远程管理软件。
        该软件存在一个安全问题,可能导致PHP源代码泄露。
        由于输入验证错误,远程攻击者通过发送一个精心构造的请求可能获得某个已知PHP程序的源代码。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1222
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1222
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200203-096
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3737
(VENDOR_ADVISORY)  BID  3737
http://www.securityfocus.com/archive/1/246861
(VENDOR_ADVISORY)  BUGTRAQ  20011221 twlc advisory: plesk (psa) allows reading of .php files
http://www.iss.net/security_center/static/7735.php
(VENDOR_ADVISORY)  XF  psa-php-reveal-source(7735)

- 漏洞信息

Plesk Server Administrator 源代码泄露漏洞
中危 输入验证
2002-03-25 00:00:00 2005-10-20 00:00:00
远程  
        
        Plesk Server Administrator是一款基于Web的Web服务器远程管理软件。
        该软件存在一个安全问题,可能导致PHP源代码泄露。
        由于输入验证错误,远程攻击者通过发送一个精心构造的请求可能获得某个已知PHP程序的源代码。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 手工修改httpd.conf,确保含有以下几行:
        
         UserDir disabled
        

        厂商补丁:
        Plesk
        -----
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.plesk.com/html/index.htm

- 漏洞信息

11643
Plesk Server Administrator PHP Source Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2001-12-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Plesk Server Administrator PHP Source Disclosure Vulnerability
Input Validation Error 3737
Yes No
2001-12-21 12:00:00 2009-07-11 09:06:00
Discovered and posted to Bugtraq by <supergate@twlc.net>.

- 受影响的程序版本

Plesk Plesk Server Administrator 1.0
- FreeBSD FreeBSD 4.4
- FreeBSD FreeBSD 4.3
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.1
- Red Hat Linux 6.2
- RedHat Linux 7.1
Plesk Plesk Server Administrator 2.0
- FreeBSD FreeBSD 4.4
- FreeBSD FreeBSD 4.3
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.1
- FreeBSD FreeBSD 4.0
- Red Hat Linux 6.2
- RedHat Linux 7.1

- 不受影响的程序版本

Plesk Plesk Server Administrator 2.0
- FreeBSD FreeBSD 4.4
- FreeBSD FreeBSD 4.3
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.1
- FreeBSD FreeBSD 4.0
- Red Hat Linux 6.2
- RedHat Linux 7.1

- 漏洞讨论

Plesk Server Administrator (PSA) is web based software that enables remote administration of web servers. It can be used on Linux and other systems that support PHP.

Due to an input validation error in Plesk Server Administrator, it is possible for a remote attacker to make a specially crafted web request which will display PHP source code.

This is acheivable by connecting to a host (using the IP address rather than the domain name), and submitting a request for a known PHP file along with a valid username.

- 漏洞利用

No exploit is required.

- 解决方案

PSA version 2.0 is not vulnerable to this issue and Plesk encourages users to upgrade.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站