CVE-2001-1212
CVSS5.0
发布时间 :2001-12-18 00:00:00
修订时间 :2008-09-10 15:09:55
NMCOES    

[原文]Cross-site scripting vulnerability in catgy.cgi for Aktivate 1.03 allows remote attackers to execute arbitrary Javascript via the desc parameter.


[CNNVD]Aktivate Shopping Cart跨站脚本执行漏洞(CNNVD-200112-112)

        
        Aktivate是一个运行Linux/UNIX平台的网上售货系统,使用MySQL作为后端支持,用Perl实现。
        Aktivate存在跨站脚本执行漏洞,可以使攻击者通过窃取Cookie等手段获得敏感信息。
        攻击者可以在运行了Aktivate的Web页面上放置包含了任意脚本代码的链接,用户如果点击了该链接,则脚本就会在用户Web浏览器环境下执行。攻击者可能借此收集到用户当前的Cookie,这些Cookie中可能包含有敏感信息。已经证实1.03版的软件是有此问题的,其它以下的低版本可能也有此问题。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1212
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1212
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-112
(官方数据源) CNNVD

- 其它链接及资源

http://www.iss.net/security_center/static/7717.php
(VENDOR_ADVISORY)  XF  aktivate-shopping-css(7717)
http://www.securityfocus.com/bid/3714
(UNKNOWN)  BID  3714

- 漏洞信息

Aktivate Shopping Cart跨站脚本执行漏洞
中危 输入验证
2001-12-18 00:00:00 2005-10-20 00:00:00
远程  
        
        Aktivate是一个运行Linux/UNIX平台的网上售货系统,使用MySQL作为后端支持,用Perl实现。
        Aktivate存在跨站脚本执行漏洞,可以使攻击者通过窃取Cookie等手段获得敏感信息。
        攻击者可以在运行了Aktivate的Web页面上放置包含了任意脚本代码的链接,用户如果点击了该链接,则脚本就会在用户Web浏览器环境下执行。攻击者可能借此收集到用户当前的Cookie,这些Cookie中可能包含有敏感信息。已经证实1.03版的软件是有此问题的,其它以下的低版本可能也有此问题。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在IE中禁止活动脚本及ActiveX控件的执行。
        厂商补丁:
        Adrian Allen
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.allen-keul.com/aktivate/

- 漏洞信息 (21187)

Aktivate 1.0 3 Shopping Cart Cross-Site Scripting Vulnerability (EDBID:21187)
cgi webapps
2001-12-18 Verified
0 Tamer Sahin
N/A [点击下载]
source: http://www.securityfocus.com/bid/3714/info

Aktivate is a shopping cart system which is geared towards Unix and Linux users, uses MySQL as a backend, and is written in Perl.

Aktivate is prone to cross-site scripting attacks. It is possible to construct a link containing arbitrary script code to a website running Aktivate. When a user browses the link, the script code will be executed on the user in the context of the site hosting the affected software.

The impact of this issue is that the attacker is able to hijack a legitimate web user's session, by stealing cookie-based authentication credentials. Other cross-site scripting attacks are also possible.

Aktivate 1.03 is known to be vulnerable, other versions may also be affected. 

https://host/aktivate/cgi-bin/catgy.cgi?key=0&cartname=axa200135022551089&desc=<script>alert(document.domain)</script> 		

- 漏洞信息

3486
Aktivate Shopping System catgy.cgi desc Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Third-party Verified

- 漏洞描述

Aktivate contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "desc" variable upon submission to the catgy.cgi script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2001-12-18 Unknow
2001-12-18 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Aktivate Shopping Cart Cross-Site Scripting Vulnerability
Input Validation Error 3714
Yes No
2001-12-18 12:00:00 2009-07-11 09:06:00
This vulnerability was submitted to BugTraq on December 18th, 2001 by "Tamer Sahin" <ts@securityoffice.net>.

- 受影响的程序版本

Aktivate Aktivate 1.0 3
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17

- 漏洞讨论

Aktivate is a shopping cart system which is geared towards Unix and Linux users, uses MySQL as a backend, and is written in Perl.

Aktivate is prone to cross-site scripting attacks. It is possible to construct a link containing arbitrary script code to a website running Aktivate. When a user browses the link, the script code will be executed on the user in the context of the site hosting the affected software.

The impact of this issue is that the attacker is able to hijack a legitimate web user's session, by stealing cookie-based authentication credentials. Other cross-site scripting attacks are also possible.

Aktivate 1.03 is known to be vulnerable, other versions may also be affected.

- 漏洞利用

"Tamer Sahin" &lt;ts@securityoffice.net&gt; provided the following example:

https://host/aktivate/cgi-bin/catgy.cgi?key=0&amp;cartname=axa200135022551
089&amp;desc=&lt;script&gt;alert(document.domain)&lt;/script&gt;

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站