CVE-2001-1211
CVSS7.5
发布时间 :2001-12-31 00:00:00
修订时间 :2008-09-05 16:25:58
NMCOS    

[原文]Ipswitch IMail 7.0.4 and earlier allows attackers with administrator privileges to read and modify user alias and mailing list information for other domains hosted by the same server via the (1) aliasadmin or (2) listadm1 CGI programs, which do not properly verify that an administrator is the administrator for the target domain.


[CNNVD]Ipswitch IMail域管理权限提升漏洞(CNNVD-200112-158)

        
        IPSwitch IMail是一个流行的基于Web的邮件收取程序,被很多ISP所使用。
        IPSwitch IMail 7.05版存在设计错误,可以使一个域的管理员接管同一主机上其他域的用户别名和邮件列表的管理操作。
        问题在于IMail检查对于某些域的别名管理会话的权限时,只是检查用户是不是一个管理员而不检查用户是不是当前域的管理员,攻击者可以任意列出、查看、增加、删除其他域的用户别名和邮件列表。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ipswitch:imail:6.2Ipswitch IMail 6.2
cpe:/a:ipswitch:imail:6.4Ipswitch IMail 6.4
cpe:/a:ipswitch:imail:6.1Ipswitch IMail 6.1
cpe:/a:ipswitch:imail:6.3Ipswitch IMail 6.3
cpe:/a:ipswitch:imail:7.0.4Ipswitch IMail 7.0.4
cpe:/a:ipswitch:imail:7.0.2Ipswitch IMail 7.0.2
cpe:/a:ipswitch:imail:7.0.3Ipswitch IMail 7.0.3
cpe:/a:ipswitch:imail:7.0.1Ipswitch IMail 7.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1211
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1211
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-158
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3766
(VENDOR_ADVISORY)  BID  3766
http://www.securityfocus.com/archive/1/247786
(VENDOR_ADVISORY)  BUGTRAQ  20011231 IMail Web Service User Aliases / Mailing Lists Admin Vulnerability
http://www.iss.net/security_center/static/7752.php
(VENDOR_ADVISORY)  XF  imail-admin-domain-change(7752)
http://support.ipswitch.com/kb/IM-20020301-DM02.htm
(UNKNOWN)  MISC  http://support.ipswitch.com/kb/IM-20020301-DM02.htm
http://support.ipswitch.com/kb/IM-20011219-DM01.htm
(UNKNOWN)  MISC  http://support.ipswitch.com/kb/IM-20011219-DM01.htm

- 漏洞信息

Ipswitch IMail域管理权限提升漏洞
高危 访问验证错误
2001-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        IPSwitch IMail是一个流行的基于Web的邮件收取程序,被很多ISP所使用。
        IPSwitch IMail 7.05版存在设计错误,可以使一个域的管理员接管同一主机上其他域的用户别名和邮件列表的管理操作。
        问题在于IMail检查对于某些域的别名管理会话的权限时,只是检查用户是不是一个管理员而不检查用户是不是当前域的管理员,攻击者可以任意列出、查看、增加、删除其他域的用户别名和邮件列表。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 控制IMail管理用户访问能力,确信只有可信任的用户能够进行管理操作。
        厂商补丁:
        Ipswitch
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.ipswitch.com/products/IMail_Server/index.asp

- 漏洞信息

10851
Ipswitch IMail listadm1 Arbitrary Mail List/User Modification
Remote / Network Access, Local / Remote Authentication Management
Loss of Confidentiality Upgrade

- 漏洞描述

Ipswitch IMail contains a flaw that may allow an attacker to gain access to unauthorized privileges. The issue is triggered when an attacker gain administrator access to one domain, allowing a remote attacker to gain control of other domains and edit the info or delete it.

- 时间线

2001-12-31 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Ipswitch IMail Domain Administration Privilege Escalation Vulnerability
Access Validation Error 3766
Yes No
2001-12-31 12:00:00 2009-07-11 09:56:00
Discovered by Zeeshan Mustafa <security@zeeshan.net> and posted to the BugTraq mailing list on December 31, 2001.

- 受影响的程序版本

Ipswitch IMail 7.0.4
- Microsoft Windows 2000 Professional SP3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
Ipswitch IMail 7.0.3
Ipswitch IMail 7.0.2
Ipswitch IMail 7.0.1
Ipswitch IMail 6.4
Ipswitch IMail 6.3
Ipswitch IMail 6.2
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
Ipswitch IMail 6.1
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0

- 漏洞讨论

Ipswitch IMail is an email server that serves clients their mail via a web interface. IMail supports most common email protocols such as SMTP, POP3, IMAP4, and LDAP etc. IMail also includes support for multiple domains, and web based administration. It runs on Microsoft Windows platforms.

There is a vulnerability with the authentication process for this web administration tool. Any valid administrator account may make changes to any domain on the server. A malicious administrator is able to abuse this access to modify or delete information associated with any hosted domain.

- 漏洞利用

This vulnerability can be exploited with a web browser.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站